Support » Fixing WordPress » Blank page 2

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    The two most common causes of this error are a corrupted .htaccess file and exceeding your server’s PHP memory limit. The .htaccess file in your WordPress directory can become corrupted after you install a plugin or make another change to your WordPress site.

    The fix is simple. All you need to do is create a new .htaccess file.

    Increasing Your PHP Memory Limit in WordPress
    define(‘WP_MEMORY_LIMIT’, ‘128M’);

    Thanks.

    where do I set define(‘WP_MEMORY_LIMIT’, ‘128M’); ?

    found it, in wp-config.

    but it doesn’t work. checked htaccess, uploaded it again. and added that memory line to wp-config. still same issue

    Please install the health check plugin and report back its findings: https://wordpress.org/plugins/health-check/

    Thanks.

    Done. Here’s the report:

    `
    ### WordPress ###

    Version: 5.1
    Language: nl_NL
    Permalink structure: /%category%/%postname%/
    Is this site using HTTPS?: Yes
    Can anyone register on this site?: No
    Default comment status: open
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.

    ### Installation size ###

    Uploads Directory: 30,58 MB
    Themes Directory: 3,83 MB
    Plugins Directory: 53,52 MB
    Database size: 1,61 MB
    Whole WordPress Directory: 127,40 MB
    Total installation size: 129,01 MB

    ### Active Theme ###

    Name: Twenty Nineteen
    Version: 1.3
    Author: het WordPress team
    Author website: https://nl.wordpress.org/
    Parent theme: Not a child theme
    Supported theme features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, editor-color-palette, responsive-embeds, widgets

    ### Other themes (1) ###

    Cambium (cambium): Version 0.1.7 by BestBlogThemes.com

    ### Must Use Plugins (1) ###

    Health Check Troubleshooting Mode: Version 1.5.1

    ### Active Plugins (1) ###

    Health Check & Troubleshooting: Version 1.2.5 by The WordPress.org community

    ### Inactive Plugins (13) ###

    Akismet Anti-Spam: Version 4.1.1 by Automattic
    Category pagination fix: Version 3.2.2 by rahnas
    Easy HTTPS (SSL) Redirection: Version 1.9 by Tips and Tricks HQ
    Edit Author Slug: Version 1.6.0 by Brandon Allen
    External Links: Version 6.8.1 by Denis de Bernardy & Mike Koepke
    Front Page Category: Version 3.0 by BinaryMoon
    Google Analytics for WordPress by MonsterInsights: Version 7.4.2 by MonsterInsights
    Jetpack by WordPress.com: Version 7.1.1 by Automattic
    Limit Login Attempts: Version 1.7.1 by Johan Eenfeldt
    Minimal Coming Soon & Maintenance Mode: Version 1.90 by WebFactory
    Really Simple SSL: Version 3.1.5 by Rogier Lankhorst, Mark Wolters
    SSL Insecure Content Fixer: Version 2.7.2 by WebAware
    Yoast SEO: Version 9.7 by Team Yoast

    ### Media handling ###

    Active editor: WP_Image_Editor_Imagick
    Imagick Module Version: 1593
    ImageMagick Version: ImageMagick 6.3.9 04/08/12 Q16 http://www.imagemagick.org
    Imagick Resource Limits:
    area: 15 GB
    disk: -1
    file: 24576
    map: 31 GB
    memory: 11 GB
    thread: Not Available
    GD Version: bundled (2.1.0 compatible)
    Ghostscript Version: Unable to determine if Ghostscript is installed

    ### Server ###

    Server architecture: Linux 2.6.32-042stab127.2 x86_64
    Web Server Software: Apache/2
    PHP Version: 7.1.16 (Supports 64bit values)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 5000
    PHP time limit: 30
    PHP memory limit: 256M
    Max input time: 60
    Upload max filesize: 64M
    PHP post max size: 64M
    cURL Version: 7.52.1 OpenSSL/1.0.1e
    SUHOSIN installed: No
    Is the Imagick library available: Yes
    htaccess rules: Your htaccess file only contains core WordPress features

    ### Database ###

    Extension: mysqli
    Server version: 5.6.34
    Client version: mysqlnd 5.0.12-dev – 20150407 – $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    Database prefix: wp_

    ### WordPress Constants ###

    ABSPATH: /home/offline/domains/vervormer.nl/public_html/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined

    ### Filesystem Permissions ###

    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable

    I found the bug.
    This one is years old. Still not solved in WordPress!

    I am using a category base. I am Dutch so I use categorie instead of category. AND I also use a custom URL structure: /%category%/%postname%/

    This means that a URL to a post can look like this:
    https://vervormer.nl/aflevering/advies-jaap-boots/

    So https://vervormer.nl/aflevering/ will go to the category page BUT then pagenation is broken.

    This is simply a bug. Using /%category%/ in custom URL slug causes this. It is allowed by WordPress but it is causing this bug.

    Do I need to submit this bug to Trac?

    Hello,

    Happy to know that you found the bug.

    I don’t think it is WP bug, but even though if you feel you can post that bug to Trac.

    I would suggest to check once in fresh WP installation and try to replicate it.

    Thanks.

    Yes I can confirm it. With Heath Check enabled, no plugins running and default theme same issue occurs.

    Will report this on Trac.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Blank page 2’ is closed to new replies.