Support » Fixing WordPress » Blank media window Mac upload

  • Resolved musingdad


    When trying to upload images using WordPress 3.0 the media window is blank (except for the header ‘Upload new media’. As such I don’t even have the option to select ‘Browser upload’ as that along with all other input fields is missing. This was working just fine when using version 2.9. Have reinstalled WordPress 3.0, recreated database but still the problem persists. Default theme and my custom theme all have the same issue. I am using a Mac and have tried three types of browser all to no avail. Strangely however if I login on a Windows machine it all works fine, so I assume this is some bug with Mac and WordPress 3.0? Please help. It’s driving me nuts and my theme is only WordPress 3 compatible.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator James Huff


    Volunteer Moderator πŸš€

    Do you have Flash 10 or higher installed?

    Yep version Just uploaded all my images using Windows 7 machine. Once there I can then manipulate them to size etc. Even though I can of course ftp some images to the same directory they are not visible to WordPress, only images uploaded using Windows.

    A few days ago the upload stopped working to add multimedia files to the blog, I say on company of my server and they said that they looked good, I’ve tried from a PC and works properly.

    I tried it with Tiger, Leopard, Snow Leopard, Firefox, Opera, Chrome, Camino, and Safari.

    In English forums some people have the same problem.

    Are we Mac users have to resign?

    Moderator keesiemeijer


    im on a Mac (Tiger) with flash version 10,1,53,64 , WordPress 3 and it works just fine for me

    Moderator keesiemeijer


    maybe if you disable javascript in your browser you get the Browser upload.

    I’m getting this problem as well. New site of mine. Blank new media options on MAC. On the PC running win 7 no problems.

    Hmmmm very strange. Also, to add more weirdness another wordpress 3.0 site works fine!



    Moderator keesiemeijer


    Have you tried:
    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    – switching to the default theme to rule out any theme-specific problems?
    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress? Please do not overwrite these folders while re-uploading! Make a backup of these folders and remove the folders and re-upload the new ones. This is especially important for the javascript stuff. Do not forget to clear your Browsers Cache

    – increasing the available memory?

    Tried all of the above.
    what i don’t get is why it works on the pc and not the mac?


    Moderator keesiemeijer


    Yeah you would conclude it’s a browser or os issue. very strange!

    Moderator keesiemeijer


    According to this same topic(Dutch)(English) it’s a server issue.
    On a server running PHP version (5.2.13) it works when browsing with a mac.
    And on a server running PHP version (5.3.2) it doesn’t work when browsing with a mac.

    He downloaded “flash uninstall” somewhere and uninstalled flash 10. After that he installed flash 9.
    Then the browser loader was visible but not the flash loader
    Then he hacked wordpress/wp-admin/includes/media.php line 1375 t/m 1360:

    // If Mac and mod_security, no Flash. πŸ™
    $flash = true;
    if ( false !==strpos(strtolower($_SERVER[‘HTTP_USER_AGENT’]), ‘mac’) && apache_mod_loaded(‘mod_security’) )
    $flash = false;

    And removed all the bold parts
    Not really a clean solution but it works for him

    maybe your host upgraded to a higher php version recently?

    I face the same problem although my two domains are running on the same 5.3.3 PHP version, with the same host but on two different Linux machines. (I tested a third domain on PHP 5.2.13, hosted elsewhere, and all was fine.)

    From Windows Vista everything is ok, but from Mac’s Snow Leopard, no matter which browser I’m using, the “Upload New Media” window is blank on one domain, perfectly fine on the other…

    I checked the two servers configuration with phpinfo.php files. I could notice only two small differences (probably unrelated but I know nothing about server conf.): bz2 was not available on the “faulty” domain, and the post_max_size was configurated to 9M instead of 15M on the domain where everything is fine.

    The phpinfo.php file of the “faulty” domain was however not displayed entirely and stopped abruptly after MYSQL_SOCKET /var/lib/mysql/mysql.sock (mysql block). Could this be related?

    Note that apart contacting my host, I’ve tried all the tricks provided under these two topics β€” without any success:

    Media Uploader missing options WP 3.0
    Fatal error: Allowed memory size???

    The only thing working for me is Keesiemeijer’s above hack, though I only had to modify media.php file, no fresh Flash install.


    Yer i have exactly the same problem.
    The hack above works thanks !!!

    It was driving me crazy ! πŸ™‚

    Mac OSX 10.6.4 with firefox 3.6.8 and PHP 5.3.2

    Like Golok I used keesiemeijer’s excellent hack, and found Flash downgrade unnecessary.

    Flash 10.1 on Mac OS X 10.5.8, Safari 5.0.1.
    Server: PHP 5.3.3 running on Linux, WordPress 3.0.1.

    I tried this hack but still nothing happens…



    Thanks Keesiemeijer – works for me (fresh instal 3.0.1 from Fantastico, no plugins)

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Blank media window Mac upload’ is closed to new replies.