WordPress.org

Forums

WP Ajax Edit Comments
[resolved] Blank lightbox (jQuery not loading in iFrame) (5 posts)

  1. raaar
    Member
    Posted 1 year ago #

    Similarly to another user I'm experiencing a blank lightbox when the edit button is clicked.

    It seems that jQuery is not loading inside the iFrame that the plugin creates when I click edit comment, so it's causing all the other javascripts to break.
    The plugin is up to date, and it works correctly on other themes, I'm just wandering if anyone experienced a similar issue with jQuery not showing up in the iFrame.

    Thanks!

    http://wordpress.org/plugins/wp-ajax-edit-comments/

  2. Ronald Huereca
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure what the problem is. Can I have a link to your site so I can test it?

    Also, have you tried Simple Comment Editing?

  3. raaar
    Member
    Posted 1 year ago #

    After further research it appears that the plugin is incompatible with the wp-foundation theme from
    http://320press.com/wp-foundation/

    I did a clean install of theme and plugin and they seem to conflict with each other

  4. Ronald Huereca
    Member
    Plugin Author

    Posted 1 year ago #

    raaar,

    Sadly this is another example of a theme not using WordPress best practices. It's deregistering the core jQuery and loading a custom version. This is a big no no.

    You can fix it by going into wp-foundation/library/bones.php and commenting out the line that says wp_deregister_script('jquery');

    I found it around line 31.

    You can read more about deregistering WordPress' built-in jQuery here: http://eamann.com/tech/dont-dequeue-wordpress-jquery/

  5. raaar
    Member
    Posted 1 year ago #

    Hi Ronald, thank you for the explanation!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.