WordPress.org

Support

Support » Installation » Blank index.php page

Blank index.php page

  • I upload teh entire WorPress on the server.

    If i go the home page of my site i have the index.php page with the code :

    <?php
    /**
    * Front to the WordPress application. This file doesn’t do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define(‘WP_USE_THEMES’, true);

    /** Loads the WordPress Environment and Template */
    require(‘./wp-blog-header.php’);
    ?>

    My wordpress folder is located in http://www.kigali-guide.com/Kigaliguide.

    Help me.

    Thanks.

Viewing 15 replies - 1 through 15 (of 33 total)
  • You need to make sure your server is set up to execute the PHP file. Typically, this is done by a handler usually within your httpd.conf file. If you’re not comfortable working in your server environment, I would suggest contacting your hosting provider.

    Yes server is set up to execute the PHP file.
    How is about httpd.conf file ?

    Every PHP page I’ve visited on your server displays the code and does not execute it. I would suggest you call GoDaddy. Especially, since right now your wp-config file is exposed and displaying your database name and username.

    I see the link but I am not using Godaddy

    When I dig your domain I see it’s on a server that is securenet server. My apologies, I thought securenet servers were Godaddys.

    I still would contact your host to see why your server is not serving PHP pages.

    Did you ever get it fixed Eugentuk?

    No

    To see if php is installed correctly, make a new file called test.php and place it in your root web dir, inside that file put this:

    PHP Code:

    <?
    phpinfo();
    ?>

    Then visit the test.php page via a web browser. If it displays your php settings then it’s installed correctly. If it shows the code, then PHP is not set up correctly on the server.

    If I upload the file test.php ,there is the same problem because WordPress is located in Kigaliguide folder.

    But with this link http://www.kigali-guide.com/test.php it displays my php settings .

    Do you have an .htaccess file in the wordpress folder? If you do, try renaming the .htaccess file and loading the wordpress install.

    I do it but no changes

    Please can any one help me with this

    [Code moderated as per the Forum Rules. Please use the pastebin]

    [Please don’t post any passwords or private info here or in the pastebin]

    I try to instal wordpress on my local host bit is still showing me the errors

    Hi Eugentuk,

    Have you contacted your hosting provider? At this point, it sounds more of a server issue and they should be able to help you.

    I’m sorry, but I dont quite get what the problem is. First I think its strange that it shows the php tagg, and the comments…

    Now I’ll ask you to try this:

    Its to look if the php is executed. Please put this code in a new document, and execute it (dont execute in wordpress, just in another direction. If this works, try in wordpress)).

    <body>
    <?php
    
    echo "hello world"; 
    
    /*test comment, if showed, and there is not 'hello world' on the screen, your host doesn't support php, or there are other problems with the hosting, and contact them.
    
    ?>
    
    <h1><p>Byebye world</p></h1>
    
    <!--If this is showed on the site, even html doesn't work. contact your host anyway... -->
    </body>

    I hope this helps.

    kind regards,

    Webbart

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Blank index.php page’ is closed to new replies.
Skip to toolbar