Support » Plugin: Image Regenerate & Select Crop » Blank/empty/no-name image size

  • Resolved Gal Baras

    (@galbaras)


    The Resize tab of EWWW Image Optimizer recently started showing the size “- 0x0”, i.e. with no name. I have a feeling it’s related to IRSC, possibly after creating a custom image size and then clearing it.

    This may also be related to synchronizing images sizes with EWWW.

    Can you please make sure this doesn’t happen?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Iulia Cazan

    (@iulia-cazan)

    Hi Gal,

    You might be right that is a hook that does not fire or there is something missing in the integration, perhaps @nosilver4u can check this in his plugin when he’ll be back from holidays. I tested but cannot replicate the issue you mention.

    Can you please check the sirsc_use_custom_image_sizes option value in your database and let me know what is there, just to make sure the option is written correctly.

    Regards,
    Iulia

    Here’s what I’ve found:

    a:1:{s:5:"sizes";a:1:{i:1;a:3:{s:4:"name";s:0:"";s:5:"width";s:0:"";s:6:"height";s:0:"";}}}

    Sure looks like a blank size to me.

    Plugin Author Iulia Cazan

    (@iulia-cazan)

    I see. That seems to be the issue, but I am not aware of a way to override the value like that (I have tested a lot of scenarios but cannot replicate it). I will make some bypass in my code for this, but in the meanwhile, you can just override it to a:2:{s:5:"sizes";a:0:{}s:6:"number";i:0;}, or simply go to the media settings and update the settings again.

    It is possible that the value was changed from outside my plugin, in the database, or from another plugin you have installed or created, or other programmatically tests?

    Please give me more details about this.

    Regards,
    Iulia

    • This reply was modified 3 months, 2 weeks ago by Iulia Cazan.

    I’ve opened a ticket on Github for @nosilver4u . The ewww_image_optimizer_disable_resizes setting also contains the entry i:0;s:4:"true" and the plugin lists a blank size on the Resize tab.

    This may have only happened on sites where I created custom sizes and then removed them with both plugins active. I’ve only found it on 2 sites.

    Looking at sirsc_use_custom_image_sizes on multiple sizes, it seems to be set on sites where I’ve added sizes and then removed them, and on two of the sites, there’s that strange blank size.

    I’ve reset the option on both my sites, so this is now both minor and not urgent.

    Plugin Author Iulia Cazan

    (@iulia-cazan)

    I included a fix in the latest release. Please upgrade and let me know if you can replicate the issue.

    Thansk, Iluia.

    I can no longer recreate the problem and EWWW now has checks to ignore blank sizes, so I think we’re good.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.