Support » Plugin: Gutenberg » Blank editing area since 3.3.0 update

  • Resolved Celso Bessa

    (@celsobessa)


    Following @designsimply request on https://github.com/WordPress/gutenberg/issues/8101#issuecomment-407494339, I am detailing the buggy behavior I an finding in a specific site in a multisite with subdomain install. WP 4.9.7 and Gutenberg 3.3.0. The console shows the messages below and they persist after cleaning all caches (server and browser, reverse proxy, storage API, etc) and forcing reload. I tested in two different Macbooks, in two different places/IPs.

    Did you build Gutenberg from source or download and install through the Plugins page?

    Installed through the Plugins page

    Can you verify the error messages you are seeing?

    index.js?ver=1532123626:37 Uncaught TypeError: Cannot read property 'keycodes' of undefined
    index.js?ver=1532123626:12 Uncaught TypeError: Cannot read property 'withFilters' of undefined
    Uncaught TypeError: Cannot read property 'withFallbackStyles' of undefined
    Uncaught TypeError: Cannot read property 'getBlockSelectionStart' of undefined

    Have you tried disabling other plugins to rule out a plugin conflict?
    What theme are you using?

    Yep, disabled all plugins and tested with Twentyseventeen, Cube and Atmosphere Pro (Genesis Framework). The same results in all cases.

    Other Notes:

    – In all other sites in the network Gutenberg works perfectly.
    – In a even more weird note, I setup another site in the network to the exactly same setup and it works.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    Would you be able to share the address of your site, it may be something strange with the path it’s receiving as you mention it works on the other sites?

    Are those the only messages you receive, or do you have anything relating to files not being found or getting other errors that may appear unrelated?

    I too have had this issue. I also have a subdomain multi-site WordPress install. In my case all sites in the network that are using Gutenberg have a broken editor. I’m forced to use the classic editor to do any post editing/creation.

    https://www.timnolte.com/
    https://www.noltefamily.org/
    https://www.faithshaping.org/

    Those are all hosted on the network https://www.ndigitals.com/ and domain mapping is being used.

    • This reply was modified 2 years, 10 months ago by Tim Nolte.
    Thread Starter Celso Bessa

    (@celsobessa)

    Hi @clorith ,thanks for the response

    > Would you be able to share the address of your site, it may be something strange with
    > the path it’s receiving as you mention it works on the other sites?

    this website http://www.modasemfrescura.com.br

    > Are those the only messages you receive, or do you have anything relating to files
    > not being found or getting other errors that may appear unrelated?

    Yes, there is an request to https://www.modasemfrescura.com.brs/?ver=1.7 which obviously fails because of the s added to .br. At first glance seems related to WPEngine strong passwords MU plugin. I will take a deeper look later and give you more info.

    Moderator Marius L. J.

    (@clorith)

    Quite curious, would you be able to do a test run in Troubleshooting Mode and see if it may be a plugin conflict with something else running there (it won’t exclude MU plugins though) ?

    If so we made the Health Check plugin for these scenarios, where you can simulate having plugins and themes switched without affecting site visitors, and allowing you to turn on individual plugins one at a time to identify conflicts.

    Here’s the log of all the JS errors I’m seeing when loading up a post to edit or create:

    load-scripts.php?c=gzip&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable,jquery-ui-slider,jquery-tou&load[]=ch-punch,iris,wp-color-picker&ver=4.9.7:9 JQMIGRATE: Migrate is installed, version 1.4.1
    vr-block.min.js?ver=4.9.7:2 Uncaught TypeError: Cannot read property ‘Placeholder’ of undefined
    at vr-block.min.js?ver=4.9.7:2
    at vr-block.min.js?ver=4.9.7:2
    (anonymous) @ vr-block.min.js?ver=4.9.7:2
    (anonymous) @ vr-block.min.js?ver=4.9.7:2
    index.js?ver=1532145469:1 wp.components.withInstanceId is deprecated and will be removed in 3.5. Please use wp.compose.withInstanceId instead.
    u @ index.js?ver=1532145469:1
    (anonymous) @ index.js?ver=1532145469:37
    387 @ index.js:47
    t @ bootstrap d747366ea47814b49e2e:19
    386 @ gutenberg.js:4040
    t @ bootstrap d747366ea47814b49e2e:19
    385 @ gutenberg.js:3978
    t @ bootstrap d747366ea47814b49e2e:19
    379 @ gutenberg.js:3636
    t @ bootstrap d747366ea47814b49e2e:19
    375 @ index.js:1
    t @ bootstrap d747366ea47814b49e2e:19
    374 @ gutenberg.js:3483
    t @ bootstrap d747366ea47814b49e2e:19
    373 @ gutenberg.js:3473
    t @ bootstrap d747366ea47814b49e2e:19
    135 @ bootstrap d747366ea47814b49e2e:62
    (anonymous) @ bootstrap d747366ea47814b49e2e:62
    gutenberg-syndicated-post.js:2 Uncaught TypeError: Cannot read property ‘registerPlugin’ of undefined
    at Object.7 (gutenberg-syndicated-post.js:2)
    at t (bootstrap f564a9e6ed472b5a7a57:19)
    at 1 (bootstrap f564a9e6ed472b5a7a57:62)
    at bootstrap f564a9e6ed472b5a7a57:62
    7 @ gutenberg-syndicated-post.js:2
    t @ bootstrap f564a9e6ed472b5a7a57:19
    1 @ bootstrap f564a9e6ed472b5a7a57:62
    (anonymous) @ bootstrap f564a9e6ed472b5a7a57:62
    gutenberg-status-plugin.js:3 Uncaught TypeError: Cannot read property ‘PluginPostStatusInfo’ of undefined
    at Object.8 (gutenberg-status-plugin.js:3)
    at n (bootstrap f564a9e6ed472b5a7a57:19)
    at 1 (bootstrap f564a9e6ed472b5a7a57:62)
    at bootstrap f564a9e6ed472b5a7a57:62
    8 @ gutenberg-status-plugin.js:3
    n @ bootstrap f564a9e6ed472b5a7a57:19
    1 @ bootstrap f564a9e6ed472b5a7a57:62
    (anonymous) @ bootstrap f564a9e6ed472b5a7a57:62
    fg.js:195 Initialized content script

    Moderator Marius L. J.

    (@clorith)

    Does this only happen with Gutenberg, or do you get similar errors with the classic editor as well?

    It looks like some arguments are being truncated there in the URL, would you also be able to test if adding the following to your wp-config.php file helps (right about the line telling you to stop editing in there:

    
    define( 'CONCATENATE_SCRIPTS', false );
    

    So I have the Health Check plugin installed and used that to completely disable all plugins, however I think it was only the specifically enabled plugins for the site since I have a bunch that are Network Enabled. I did change these to all false:

    define('CONCATENATE_SCRIPTS', false);
    define('COMPRESS_SCRIPTS', false);
    define('COMPRESS_CSS', false);
    define('ENFORCE_GZIP', false);

    I changed my site’s PHP version to 7.2 from 7.0, not that a PHP version would have anything to do with Gutenberg not showing given that is pretty much JavaScript. I’m on SiteGround hosting, and I’ve purged the cache on all sites. For me right now all of my sites are showing a blank editing area instead of Gutenberg.

    • This reply was modified 2 years, 10 months ago by Tim Nolte.
    Moderator Marius L. J.

    (@clorith)

    Truly odd, do you have another site you could check and see if you are experiencing the same issue there (on the same host or another host)?

    Also, just for the fun of it, have you tried completely deleting Gutenberg and re-installing it fresh in case something bad happened during the installation process behind the scenes?

    So, it’s strange as I use the Health Check plugin, and turned on Troubleshooting Mode to disable plugins, and the Gutenberg editor was still not working. Well, I just went and performed some plugin and theme updates that popped up. I happened to check the Gutenberg demo page and it was working. There was only one plugin update for EmbedPress. I tracked down the changelog and found that it was the culprit plugin. I’m guessing that the Health Check plugin doesn’t actually disable Network Enabled plugins, so I’ll have to remember that in the future. Maybe I’ll investigate this and submit a PR to make sure the Health Check plugin can disable Network Enabled plugins. Thanks for taking time on this.

    Moderator Marius L. J.

    (@clorith)

    Awesome, I’m glad to hear you found the reason and got it sorted 🙂

    And yes, we love contributions so please feel free to do so (or just open a ticket for discussion so we can come up with a good approach to this)

    Thread Starter Celso Bessa

    (@celsobessa)

    First: sorry for not answering before. I had a lot of work in the last weeks.

    In my case, the last update (3.5.0) resolved the issued.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Blank editing area since 3.3.0 update’ is closed to new replies.