Support » Plugin: Site Kit by Google » Blank Dashboard

  • Resolved LilGames

    (@lilgames)


    I set this up a few days ago and it was working fine. Today i updated the plugin and now the Sitekit Dashboard is blank.

    Clicking on the plugin name in the admin menu, shows nothing. Clicking “Dashboard” shows nothing. Clicking “Analytics” shows nothing. Clicking “Settings” shows nothing. Basically, you broke your plugin.

    Version 1.1.1

    I am deactivating the plugin for now. (and have to manually put my tag codes back in!)

    • This topic was modified 1 month, 3 weeks ago by LilGames.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    @lilgames Thanks for reporting, hopefully I can assist. Can you attempt the following steps in order to get your dashboards populating again?
    – Check your site for a browser incognito window
    – Attempt disconnecting and reconnecting the Analytics module again

    If that fails can you let me know the following:
    – What security plugins are you using (if any)
    – What console errors appear on the page with the blank screen

    I don’t use private or incognito to visit my own sites’ admin dashboard.

    I re-activated the plugin and re-connected. And don’t forget, it was WORKING, before the latest update I reported.

    The page area that should have Sitekit info is BLANK without errors. The bottom says:

    “Thank you for creating with WordPress. Version 5.3”

    Security plugins: Wordfence (free version).

    I also cleared all caches.

    Console log shows two major errors:

    Uncaught TypeError: Cannot read property ‘call’ of undefined
    at __webpack_require__ (googlesitekit-dashboard.js?ver=1.1.1:1)
    at Object.2 (commons.js?ver=1.1.1:1)
    at __webpack_require__ (googlesitekit-dashboard.js?ver=1.1.1:1)
    at Module.202 (googlesitekit-dashboard.js?ver=1.1.1:1)
    at __webpack_require__ (googlesitekit-dashboard.js?ver=1.1.1:1)
    at n (googlesitekit-dashboard.js?ver=1.1.1:1)
    at googlesitekit-dashboard.js?ver=1.1.1:1
    at googlesitekit-dashboard.js?ver=1.1.1:1

    Uncaught TypeError: Cannot read property ‘call’ of undefined
    at __webpack_require__ (allmodules.js?ver=1.1.1:1)
    at Object.2 (commons.js?ver=1.1.1:1)
    at __webpack_require__ (allmodules.js?ver=1.1.1:1)
    at Object.9 (commons.js?ver=1.1.1:1)
    at __webpack_require__ (allmodules.js?ver=1.1.1:1)
    at Object.27 (commons.js?ver=1.1.1:1)
    at __webpack_require__ (allmodules.js?ver=1.1.1:1)
    at Object.55 (commons.js?ver=1.1.1:1)
    at __webpack_require__ (allmodules.js?ver=1.1.1:1)
    at Object.<anonymous> (allmodules.js?ver=1.1.1:1)

    Plugin Support James Osborne

    (@jamesosborne)

    Hi @lilgames The reason I asked to check from a browser incognito window was because AdBlockers or browser extensions (such as VPNs) can interfere with reporting.

    Can you temporarily deactivate the WordFence plugin during testing and then disconnecting the Analytics module before connecting again?

    Oh, I didn’t interpret “Check your site for a browser incognito window” to mean to USE the browser in incognito mode.

    YES it works if I use incognito mode.

    Plugin Support James Osborne

    (@jamesosborne)

    @lilgames Thanks for the update, good to know! And my bad, that was indeed a typo!

    I see this bug was addressed with an update. However, it persists for me on the “Dashboard” section of the plugin.

    In the “Dashboard” section of WordPress, I can see SiteKit content now (could not before).

    If I click “G Site Kit” or “Dashboard” under G Site Kit, the page is blank and there are now 3 different JS errors than before.

    If I click Search Console, Analytics or Settings, the page displays content as it should with no JS errors.

    The errors from the Dashboard section of the plugin are:

    react-dom.min.js?ver=16.9.0:103 TypeError: Invalid attempt to spread non-iterable instance
    at _nonIterableSpread (vendor.js?ver=1.1.2:1)
    at t.exports (vendor.js?ver=1.1.2:1)
    at je (react-dom.min.js?ver=16.9.0:78)
    at ph (react-dom.min.js?ver=16.9.0:215)
    at lh (react-dom.min.js?ver=16.9.0:126)
    at O (react-dom.min.js?ver=16.9.0:121)
    at Sb (react-dom.min.js?ver=16.9.0:213)
    at wh (react-dom.min.js?ver=16.9.0:160)
    at fd (react-dom.min.js?ver=16.9.0:160)
    at react-dom.min.js?ver=16.9.0:163
    ve @ react-dom.min.js?ver=16.9.0:103
    f.componentDidCatch.c.callback @ react-dom.min.js?ver=16.9.0:114
    yg @ react-dom.min.js?ver=16.9.0:62
    xg @ react-dom.min.js?ver=16.9.0:61
    Ti @ react-dom.min.js?ver=16.9.0:148
    unstable_runWithPriority @ react.min.js?ver=16.9.0:26
    Ma @ react-dom.min.js?ver=16.9.0:52
    Ia @ react-dom.min.js?ver=16.9.0:140
    Sb @ react-dom.min.js?ver=16.9.0:213
    wh @ react-dom.min.js?ver=16.9.0:160
    fd @ react-dom.min.js?ver=16.9.0:160
    (anonymous) @ react-dom.min.js?ver=16.9.0:163
    kh @ react-dom.min.js?ver=16.9.0:119
    id @ react-dom.min.js?ver=16.9.0:163
    render @ react-dom.min.js?ver=16.9.0:228
    (anonymous) @ googlesitekit-dashboard.js?ver=1.1.2:1
    react-dom.min.js?ver=16.9.0:103 Error: Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args%5B%5D=TypeError%3A%20Invalid%20attempt%20to%20spread%20non-iterable%20instance&args%5B%5D= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.
    at Pc (react-dom.min.js?ver=16.9.0:66)
    at react-dom.min.js?ver=16.9.0:76
    at T (react-dom.min.js?ver=16.9.0:87)
    at ph (react-dom.min.js?ver=16.9.0:218)
    at lh (react-dom.min.js?ver=16.9.0:126)
    at O (react-dom.min.js?ver=16.9.0:121)
    at ze (react-dom.min.js?ver=16.9.0:118)
    at react-dom.min.js?ver=16.9.0:53
    at unstable_runWithPriority (react.min.js?ver=16.9.0:26)
    at Ma (react-dom.min.js?ver=16.9.0:52)
    ve @ react-dom.min.js?ver=16.9.0:103
    c.callback @ react-dom.min.js?ver=16.9.0:114
    yg @ react-dom.min.js?ver=16.9.0:62
    xg @ react-dom.min.js?ver=16.9.0:61
    Ti @ react-dom.min.js?ver=16.9.0:149
    unstable_runWithPriority @ react.min.js?ver=16.9.0:26
    Ma @ react-dom.min.js?ver=16.9.0:52
    Ia @ react-dom.min.js?ver=16.9.0:140
    ze @ react-dom.min.js?ver=16.9.0:118
    (anonymous) @ react-dom.min.js?ver=16.9.0:53
    unstable_runWithPriority @ react.min.js?ver=16.9.0:26
    Ma @ react-dom.min.js?ver=16.9.0:52
    mg @ react-dom.min.js?ver=16.9.0:52
    V @ react-dom.min.js?ver=16.9.0:52
    kh @ react-dom.min.js?ver=16.9.0:119
    id @ react-dom.min.js?ver=16.9.0:163
    render @ react-dom.min.js?ver=16.9.0:228
    (anonymous) @ googlesitekit-dashboard.js?ver=1.1.2:1
    react-dom.min.js?ver=16.9.0:66 Uncaught Error: Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args%5B%5D=TypeError%3A%20Invalid%20attempt%20to%20spread%20non-iterable%20instance&args%5B%5D= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.
    at Pc (react-dom.min.js?ver=16.9.0:66)
    at react-dom.min.js?ver=16.9.0:76
    at T (react-dom.min.js?ver=16.9.0:87)
    at ph (react-dom.min.js?ver=16.9.0:218)
    at lh (react-dom.min.js?ver=16.9.0:126)
    at O (react-dom.min.js?ver=16.9.0:121)
    at ze (react-dom.min.js?ver=16.9.0:118)
    at react-dom.min.js?ver=16.9.0:53
    at unstable_runWithPriority (react.min.js?ver=16.9.0:26)
    at Ma (react-dom.min.js?ver=16.9.0:52)

    Plugin Support James Osborne

    (@jamesosborne)

    @lilgames Thanks for the update. Are you encountering these same errors using a browser incognito window? From your browser incognito window can you attempt to add ?ao_noptimize=1to the URL, which would disable that plugin per request.

    Today I can confirm that under normal viewing (ie: NOT an incognito browser) the dashboard main page for site kit is displaying. However there is a red alert icon in the upper left of the window area and no information next to it.

    So let me repeat: The problem I previously relayed is gone (maybe it was a caching issue) and now the dashboard displays content but there is an alert icon just above the “G Site Kit” logo. This alert also appears if using Incognito mode in Chrome.

    Console reports no errors.

    And to be even more specific, even though there is an alert icon, the rest of the Sitekit dashboard page is now displaying data and graphs, so as far as use for me, the plugin is now doing what it should be doing.

    Version 1.1.2

    If I add ‘?ao_noptimize=1’ to the URL, I get “Sorry, you are not allowed to access this page.”

    • This reply was modified 1 month, 1 week ago by LilGames.
    Plugin Support James Osborne

    (@jamesosborne)

    @lilgames Thanks for the update. I am not familiar with this issue you are currently encountering, but if you can share a screenshot I can certainly look into it. There are various browser add ons you can use to share screenshots via URL. Alternatively if you share your Site Health information I can try and recreate the same setup to troubleshoot further.

    Screenshots:
    https://www.sporeproductions.com/wp-content/uploads/2019/12/site-kit-alert.png
    https://www.sporeproductions.com/wp-content/uploads/2019/12/site-kit-in-page.png

    Site health:

    
    ### wp-core ###
    
    version: 5.3
    site_language: en_US
    user_language: en_US
    timezone: America/Toronto
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/spore775/sporeproductions.com
    wordpress_size: 460.18 MB (482535567 bytes)
    uploads_path: /home/spore775/sporeproductions.com/wp-content/uploads
    uploads_size: 45.03 MB (47214600 bytes)
    themes_path: /home/spore775/sporeproductions.com/wp-content/themes
    themes_size: 35.17 MB (36881576 bytes)
    plugins_path: /home/spore775/sporeproductions.com/wp-content/plugins
    plugins_size: 55.49 MB (58184926 bytes)
    database_size: 9.58 MB (10043655 bytes)
    total_size: 605.45 MB (634860324 bytes)
    
    ### wp-dropins (1) ###
    
    object-cache.php: true
    
    ### wp-active-theme ###
    
    name: Divi (Divi)
    version: 4.0.8
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    parent_theme: none
    theme_features: post-thumbnails, custom-background, automatic-feed-links, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /home/spore775/sporeproductions.com/wp-content/themes/Divi
    
    ### wp-themes-inactive (3) ###
    
    Divi Child: version: 1.0.0, author: Ray Boutin
    Twenty Nineteen: version: 1.4, author: the WordPress team
    Twenty Twenty: version: 1.0, author: the WordPress team
    
    ### wp-mu-plugins (1) ###
    
    ET Support Center :: Must-Use Plugins Autoloader: author: Elegant Themes, version: (undefined)
    
    ### wp-plugins-active (13) ###
    
    Async JavaScript: version: 2.19.07.14, author: Frank Goossens (futtta)
    Autoptimize: version: 2.5.1, author: Frank Goossens (futtta)
    Divi Forms Google reCaptcha: version: 1.1.3, author: Trumani
    Duplicate Post: version: 3.2.4, author: Enrico Battocchi
    Enable Media Replace: version: 3.3.7, author: ShortPixel
    GS Logo Slider PRO: version: 1.0.2, author: Golam Samdani
    IndieDev Game Marketer: version: 2.0.7, author: IndieDev.tools
    Redirection: version: 4.5.1, author: John Godley
    SG Optimizer: version: 5.3.9, author: SiteGround
    ShortPixel Image Optimizer: version: 4.15.2, author: ShortPixel
    Site Kit by Google: version: 1.1.2, author: Google
    Wordfence Security: version: 7.4.2, author: Wordfence
    Yoast SEO: version: 12.7, author: Team Yoast
    
    ### wp-plugins-inactive (4) ###
    
    Wordfence Assistant: version: 1.0.7, author: Wordfence
    WP-Optimize - Clean, Compress, Cache: version: 3.0.14, author: David Anderson, Ruhani Rabin, Team Updraft
    WP-Sweep: version: 1.1.1, author: Lester 'GaMerZ' Chan
    WP Disable: version: 1.5.21, author: optimisation.io - jody nesbitt
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 3.12.18-clouder0 x86_64
    httpd_software: Apache
    php_version: 7.3.12 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 3000
    time_limit: 120
    memory_limit: 768M
    max_input_time: 120
    upload_max_size: 128M
    php_post_max_size: 128M
    curl_version: 7.59.0 OpenSSL/1.0.2r
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.40-84.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/spore775/sporeproductions.com/wp-content
    WP_PLUGIN_DIR: /home/spore775/sporeproductions.com/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 768M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Plugin Support Renee Johnson

    (@reneesoffice)

    @lilgames sorry for the delay in response. Thanks for providing this information. Could you try to update to the latest version 1.1.4 and let us know if the issue persists?

    LilGames

    (@lilgames)

    Looks like it is working as intended now!
    🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Blank Dashboard’ is closed to new replies.