Support » Plugin: BackWPup - WordPress Backup Plugin » Black Screen and no backup when run BackWPup

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m getting this on one of my installations too. WordPress 3.4 and BackWPup Version 2.1.11.

    Upon running the job from the ‘Jobs Overview’, the backup tries to start but I get a Black screen with no output or activity.

    Any ideas?

    seems to be a recurrent problem, according to the offical forum.
    Everybody is waiting for 3.0 release.
    Maybe we could help daniel in the developement !

    Just done a little testing and found that if I deactivate, uninstall then re-install the plugin it appears to work again.

    I recently moved my WordPress site from a local development machine to the live server so perhaps this is what caused the problem?

    I have the same problem as xclamation. Moved the website from the testing environment to the productive server (other hosting provider) and now no backups are created, the log files are empty and a blank output screen is shown.

    Had a similar problem with a production server. You can try this:

    1. Upload this code as test.php on your production server. Replace with your site.

    $mysite = "";
    error_reporting(E_ALL & ~E_NOTICE);
    ini_set('display_errors', TRUE);
    $html = file_get_contents($mysite);
    if ($html !== false) {
    	echo htmlentities($html);
    } else {
    	echo "No data from $mysite";

    2. Open in your browser. Replace with your site.

    Does something like this appear?

    Warning: file_get_contents( failed to open stream: Connection refused in /...
    No data from

    3. If yes, add this line define('ALTERNATE_WP_CRON', true); in wp-config.php, then manually start the job in backend.

    4. Now BackWPup probably works, but only manually!

    It’s a problem of production servers behind firewalls, load balancers or similar, they can’t access the own site via http.

    Adding define('ALTERNATE_WP_CRON', true); in wp-config.php worked for me, thanks for the tip.

    @ov3rfly: I’ve tested the PHP script you provided and my server didn’t fail to show the results. But Backwpup is failing anyway.

    Although, after setting define(‘ALTERNATE_WP_CRON’, true); in wp-config.php worked fine, when executing manually.

    There is some strange issue with cURL php script in WordPress that is causing long delays in the cron processes. I was able to solve the issue with BackWPup by installing Core Control plugin, and using it to deactivate usage of cURL in WordPress.
    I don’t know for sure if it can cause new different issues, but this setting managed to workaround the backwpup issue.

    It is not an ideal scenario, but this workaround worked fine for me. I Hope Daniel can provide some feedback about taking care of this new issues in the next version of this awesome script.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Black Screen and no backup when run BackWPup’ is closed to new replies.