Support » Fixing WordPress » Black diamonds with question marks in my restore

  • Hi. I’ve seen a few posts about this but none of the solutions seem to work for me. I restored a backup via MySQL database and now these strange characters are throughout my blog. They appear to be where I have a double-space or an apostrophe. I have tried changing charset from the default UTF-8 but that only takes care of one problem to cause others. I have also done a search and replace of a few strings but that also did not solve the problem. Can anyone help? Thanks in advance. Oh, and here is an example:

    Damien Riley

Viewing 3 replies - 1 through 3 (of 3 total)
  • Solved the problem. I detected the charset automatically in Firefox through View>>>Encoding. I tried a few until one worked. This one worked:


    I traded the default UTF-8 charset in settings>>>reading in WP-admin and voila! The annoying unwanted characters disappeared. If there are any known issues working with this charset please let me know.

    Just wanted to say a massive thank you for posting this: it suddenly started happening, without any apparent reason in a 2.9.2 install.

    All is now working,so thank yo!

    Best wishes


    Agreed. Immensely helpful. Switched hosting environments and all of a sudden had the strange marks. Thought it would involve a bunch of database changes. Relieved indeed!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Black diamonds with question marks in my restore’ is closed to new replies.