Support » Plugin: BJ Lazy Load » BJ Lazy load doesn’t work with Internet Explorer

  • Hi,
    After using the plugin for some time I noticed that none of my images below the fold load on Internet Explorer (currently at version 11). They do load well on Chrome and other browsers.

    Can you support, please?

    Best regards,
    Andrejs

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi! Be aware that Internet Explorer is absolutely deprecated since 2018. You should use another navigator, Chrome, Edge, Firefox or Safari.
    In my case I warn the user who has internet Explorer to upgrade to a new navigator 😉

    Thread Starter theathleteblog

    (@theathleteblog)

    Hi,
    I know Internet Explorer is outdated, but the reality is that ~30% of users still use it (according to my analytics ~25%). Adding a notice on my blog to use other browsers is not the best solution – people will just ignore it.

    Is this plugin still supported? Can a line of code be added to fix IE issues?

    Global analytics says 3% for explorer:
    https://www.stetic.com/market-share/browser/

    I’m not sure if it’s still supported. You may disable the plugin if the navigator is internet explorer but that should be hard coded

    Thread Starter theathleteblog

    (@theathleteblog)

    thanks for the feedback. Do you happen to know if there’s a function that I can add to not run the plugin if the browser is IE?

    I have looked for it on “plugin organizer” plugin, but it looks like it’s not possible.

    It’s a bit tricky and you have to know programming,
    you should put on your functions.php (on your active theme) an wp_dequeue_script so the JS file of bj-lazy-load stops loading if the browser is IE. This probably works

    https://developer.wordpress.org/reference/functions/wp_dequeue_script/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘BJ Lazy load doesn’t work with Internet Explorer’ is closed to new replies.