Support » Plugin: FooGallery - Image Gallery WordPress Plugin » Bizarre Thumbnail Behaviour

  • Hi!

    Thumbnails are giving me a headache, haha. Generally cropping thumbnails for use in FooG using WordPress’ inbuilt method works – except when it doesnt. I’ve been trying to find a reason why/how this is happening but i cant isolate it at all.. About half of my custom cropped thumbnails are totally uncooperative and will not be applied to the items.

    In the WP “edit picture” UI it’ll say its saved the crop. Then often it’ll appear correct in the gallery edit view in the “manage items” section – but it’ll be reverted back to the original in the “Gallery Preview” tab. Other times the good edited thumbnail will have appeared in both, but still wont be reflected on the webpage itself.

    The galleries are all “responsive web gallery” .. It doesnt matter i I disable lazy image loading, it makes no difference if i delete the thumbnail cache (whether through the UI or FTP) or disable other plugins, or view from a retina or non retina machine.

    I have a feeling this will be difficult to troubleshoot, so – sorry about this! :O

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author bradvin

    (@bradvin)

    hi there

    For your gallery settings, choose the thumb size as 150×150, which should be the same size as your thumb settings under Settings -> Media.

    You can force foogallery to always use the WP generated thumbs by editing your gallery, then scrolling down to the Thumbnails metabox on the right side of the screen and enabling “Force Original Thumbs” then saving your gallery.

    Aha! Thanks for the reply. 🙂 This has helped me get a bit further.

    I was mistaken when I said i was using Responsive Web Album, I was using All In One Stacks. Oops – that might not be bad now as I’ve tried both.

    That worked for the Gallery page itself but doesnt work for the All In One Stack Album (which I was trying to use instead of individual gallery pages). Is the responsive web gallery caching images somewhere else? Is it not pulling the correct info from the galleries it contains somehow? It does the same for the Responsive Web Album view – basically I think the Album views are displaying thumbnails wrong*? (but I might just be doing something dumb)

    On those album pages it displays most of the thumbs as the non-cropped varients (Some of them not square anymore) I tried clearing that gallery’s cache and that made no difference either.

    Good luck, hopefully its something at my end. 😀

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi again,

    Would you please trying clearing the HTML and CSS cache buttons in FooGallery -> Settings?

    If you have any other WordPress or server side caching enabled please make sure those caches are cleared as well.

    Let us know if that makes a difference.

    Hi, thanks again –

    I just disabled wp_cache, and cleared the HTML and CSS cache in FooGallery settings (as well as browser caches). That has made both versions of the gallery (wp page based and single pile album) work the same as each other, so that makes it easier to figure everything out now.

    So I’ve just run through the whole process again (force original thumbs to get the crops right, clearing of caches) but with Retina display disabled – It works as you suggested perfectly – but as soon as I enable 2x some of the thumbs revert to a non-square, full dimension versions (though it still looks right in “manage items” view.. So it actually seems related to high res thumbs and I was just getting confused by cached versions before.

    So I think:

    If I have retina mode enabled – “force original thumbnails” makes many of my pics “full ratio” non-cropped thumbnails.

    Turning off force original thumbnails displays them as the correct square shape, but the only cropping control I can use on them is the little 9 point grid thing, custom crops don’t work at all.

    I wonder if this is intended functionality or replicable at your end or if it’s just my setup? (I’d take a guess it’s because the WP inbuilt crop tool doesn’t generate a cropped 2x thumbnail at the point it saves the file so telling Foo to use original thumbs makes it default to showing the full image variant instead?) If it’s intended functionality I’m sorry for taking up your time! 😅

    Plugin Support phillcoxon

    (@phillcoxon)

    @bradvin – would you please review @mixel‘s follow up query please?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.