Support » Plugin: Disable Comments - Remove Comments & Protect From Spam » Bizarre flashing URL box problem seemingly related to this plugin

  • Resolved Tim

    (@timwakeling-1)


    OK, I’ll be the first to admit as a fairly experienced developer that I don’t understand why this plugin would cause the problem I’m describing, but I can almost consistently replicate it without any other plugins enabled and the default theme selected.

    In the TinyMCE editor, when I highlight a word and click to make it a link, then hover over the blue square “Enter” button on the link pop-up, the whole pop-up flashes uncontrollably and rapidly on and off, making it hard if not possible to actually click the button and apply the link. I then deactivate “Disable Comments” (which was the only plugin active) and the box no longer flashes when I try to add a link. Then I re-enable the plugin and it starts doing it once more.

    Bizarrely, it also only seems to do this when my browser is maximised on my large screen monitor (2560×1440), not when it’s smaller.

    As I say, I cannot imagine why a disable comments plugin, especially one that’s so widely used, would do this – but it seems to be doing it. Have you encountered this before at all, and any idea why it happens?

    Tim

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Samir Shah

    (@solarissmoke)

    I’m not able to reproduce this, but have made some changes in version 1.9.0 which might help.

    Thread Starter Tim

    (@timwakeling-1)

    Thanks for your efforts, Samir!

    I’m still trying to track down the problem, and if I identify something specific, I’ll let you know. Otherwise it may be best to leave it for now. šŸ™‚

    Pat K

    (@blackcapdesign)

    FYI: this happened to me as well; using the classic editor, WP 5.2.2 and Disable Comments v1.9. I deactivated all plugins & switched to Twenty Seventeen theme. Only after disabling this plugin (Disable Comments) did the edit/insert link popup stop flashing. (Highlighting text and clicking ‘Insert/Edit Link’ initiates the popup, but hovering over the popup makes it flash quickly on and off, making it unusable.) I rolled back to v1.8; no change.

    I have Disable Comments installed on other sites, and have never seen this before. There is another site running on the same server as this site with the same plugins plus additional plugins and I can’t reproduce this problem. Very strange. Also, no JavaScript error reported.

    Unfortunately, the site is in development, so I’m not able to share the link.

    The solution (sort of) in my case: click publish. If I paste or type in content, and try to create a link, it flashes. But if I publish the page or post, I’m then able to create links using the link button.
    pk

    Thread Starter Tim

    (@timwakeling-1)

    That’s really interesting, Pat. I’m fairly sure in my case it applied to published pages as well.

    I also discovered that the problem doesn’t apply to the new Gutenberg editor, so with all my sites moving to that, it became less of an issue. I would still be very keen to hear from anyone who finds the exact cause! šŸ™‚

    Tim

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Bizarre flashing URL box problem seemingly related to this plugin’ is closed to new replies.