Support » Fixing WordPress » Bizarre 404 errors on certain dashboard functions

  • Resolved dangerouslilly


    Sadly, I can’t pinpoint when the problem started because I don’t recall how long it’s been since I tried to successfully do the things that are resulting in a 404.
    Things like: When viewing the Spam comments, I can “delete permanently” on each individual comment but I cannot select the whole page of comments, nor can I just click on “empty spam”. The latter two result in a 404.
    I can’t delete a plugin, I get a 404. I tried to re-update WordPress, wondering if it was a botched update. It does the update but when it’s time to display the “The update was successful, here’s what we changed” page (about.php) it 404s. I looked, and the about.php IS in my file structure.
    I don’t get a 404 from anything other than Dashboard admin stuff, so I can’t even show you what the problem is.

    Things I’ve done:
    *Deactivated every, single stinking plugin.
    *I use GoDaddy for hosting, so I called them to make sure there wasn’t an error on their end that they could detect. Using Godaddy, I can look at the File Manager and look at the files in “history” view; I can revert the files to how they were on any day in the last month. That’s a good trick for if I get hacked, to quickly fix the site. The revert didn’t work, I even reverted to prior to the 3.5.1 update.
    *Activated the default WP theme instead of my usual theme.

    So it doesn’t seem to be the host; it doesn’t seem to be a plugin, or the theme, or a botched WP update. It doesn’t seem to be a hack. I’m out of ideas.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Lilly, I’m also running into the same 404 issues. Right now when I try to run auto-updates or delete a plugin I get a 404 page. This just started happening today.

    I also host with GoDaddy and I suspect there is an issue with their .htaccess file but that’s as far as I’ve gotten.

    I’ve tried lots of stuff, including replacing a majority of WordPress core files but I can’t find the issue.

    It’s also not effecting all of my WordPress sites. I own two other hosting accounts with GoDaddy, both with WordPress installs and they don’t have any issues. I just run plugin updates and version updates from 3.5 to 3.5.1.

    I also compared the .htaccess files and they are the same, so if it is related to that, it’s not the file but how the server is reading that file…if it’s related at all.

    Lilly, this would be totally random, but in my case I found a .htaccess file in the wp-admin folder. Once I deleted that file, everything started working again.

    If this is what’s going on with your site, that would be amazing. If not, good luck!!

    Oh one thought, in all my searches, it seemed that some people had success re-saving their permalinks. You might try that, if you haven’t already.

    Troy, you fixed it!

    Sorta. I too found an htacess file in the wp-admin folder. I deleted it…that didn’t work. But I decided to look more into the htaccess thing.
    Ages ago I had installed a plugin called Bulletproof, for additional security because my WP site was being hacked a lot. I no longer have the plugin installed, so it can’t be that an update to Bulletproof changed the htacess file. It must mean that a change in 3.5.1 made something in the htaccess file break something in the dashboard. That’s about as much as I’ve figured out.
    I solved the problem by replacing the code with the bare-bones WP recommended code, and then slowly added in the bits I knew I needed to keep, like blocking a few IPs, hotlinking, protecting the wp-config and htaccess. I haven’t tweaked anything else and now all of my 403 errors are resolved.
    Yay, I don’t have to reinstall the entire site! (As a long-time Windows user, it used to be that sometimes everything just got so effed up that you had to wipe and reinstall, I was preparing to do that)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Bizarre 404 errors on certain dashboard functions’ is closed to new replies.