WordPress.org

Forums

[resolved] Bitnami stack with MU Domain Mapping plugin (11 posts)

  1. CybreTron
    Member
    Posted 3 years ago #

    I have successfully install the Bitnami WordPress stack and activate multi-site. However, when I installed the MU Domain Mapping plugin, an error

    "The domain mapping plugin only works if the site is installed in /. This is a limitation of how virtual servers work and is very difficult to work around."
    is shown.

    I then uninstall the stack and tried to install it in /. But the installer won't let me as it said the folder is not empty.

    I am wondering what else I have to set or what can I do to make it work.

  2. That's a Bitnami issue, then. Can't you just install it manually? Copy WP into the root HTML folder?

  3. You cannot have the folder name in the URL of the network. Not if you are trying to map domains, because that folder name winds up in the mapped domain.

  4. CybreTron
    Member
    Posted 3 years ago #

    Thanks Ipstenu, what you mean install it manually is that I install LAMP and then WordPress? Actually the default installion path that Bitnami suggests is /opt/wordpress-3-3-2. I have tried / but it didn't allowed and now I install it in /wp. With no luck the same problem appeared.

    Copy WP into the root is that means copy my current /wp/ contents to /? That's include mysql and apache2, or I just need to copy /apps?

    Thanks Andrea, I realized I have /wordpress/ as the folder name but not / after I activated multi-site, but I cannot change it even in super admin mode. Is there any setting that I can do to solve this issue? Should I uninstall Bitnami stack and install LAMP then WordPress instead? Let's say I have two domains http://www.first.com and http://www.second.com, should I type http://www.first.com to replace 127.0.0.1 during installation?

    I am new to WordPress and I think that's the wave of the future, please help, many thanks :D

  5. I know sod all of Bitnami.

    I know this.

    When I install WordPress locally, I can put it in the 'root' of localhost (so if I go to localhost in my browser, it pops up as WordPress right away).

    So wherever THAT is on your install, that's where WP needs to be.

    Basically you need to make sure WP is installed so you have domain.com/ as the start, NOT domain.com/wp

    Does that make sense?

  6. CybreTron
    Member
    Posted 3 years ago #

    Thanks again,

    It fully make sense, so that means I need to uninstall Bitnami stack and install LAMP and then WordPress in sequence? And when I install WordPress I need to make sure to enter the address is 'root' ('/127.0.0.1/')? Is that all?

    Sorry for asking so much details as I am a total WP newbie.

    p.s. I am using opensuse 12.1

  7. Is there any setting that I can do to solve this issue?

    no you have to reinstall it.

    And when I install WordPress I need to make sure to enter the address is 'root' ('/127.0.0.1/')? Is that all?

    you need to make sure it has a fully qualified domain name. If this is on localhost, fake a domain in your hosts file if you have to.

  8. CybreTron
    Member
    Posted 3 years ago #

    Thanks a lot for your reply Andrea.

    One more question, if I have a registered domain name, say, http://www.abc.com (and it already pointed to my current fixed IP address), can I enter it in replacing /127.0.0.1/org without a fake domain?

    Thanks in advance

  9. Should, sure. It's the same idea :)

  10. asyak
    Member
    Posted 2 years ago #

    I know this issue is already solved installing a LAMP and then manually installing WordPress on top of it. I'm sorry for not having discovered it earlier and help on solving this issue. However for future reference I'd like to mention that you can also have Multisite with BitNami. You can find a guide of how to configure Multisite if you are using BitNami in our wiki (I'm from the BitNami team).

  11. asyak - That's awesome! Thanks :)

Topic Closed

This topic has been closed to new replies.

About this Topic