Support » Plugins and Hacks » WordTwit Twitter Plugin » Bit.ly shortening not happening with 3.0

Bit.ly shortening not happening with 3.0

  • Hello, I have gotten the new 3.0 version of the plugin to work fine and be backward compatible with the old 2.x URL link shortner (is that gone forever?).

    However, bit.ly shortening doesn’t appear to be working, the plugin outputs the full wordpress URL, even though I’ve entered in my bit.ly username and api key. Is anyone else noticing this?

    Thanks for the great work.


Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author BraveNewCode Inc.



    (is that gone forever?).

    Yes, basically. The old version was updated because it stopped working due to the Twitter API update. The Pro code is now in the current free version of WordTwit Pro.

    Is anyone else noticing this?

    We tested this locally and it appears to be working as expected. Is bit.ly the only shortening service that does not work in your installation?

    You’re welcome.

    Thanks for responding…it looks like WordPress shortening works. I tried bit.ly with and without an account/api and it doesn’t shorten either way. I also tried this on a less configured (more plain vanilla blog) and no bit.ly shortening either.

    Any advice?

    Looks like is.gd works as well.

    Plugin Author BraveNewCode Inc.


    If you’d like, we can test your bit.ly username/api on our end. You can send them to info@bravenewcode.com (include a link to this thread) and we’ll be happy to take a look.

    Thanks for the quick response – if possible I’d rather not send my api key around. FWIW, I’ve done some additional testing.

    TinyURL: works

    When I go back to bit.ly it looks “stuck” on WordPress shortening. That’s what I’m using for now.

    When I take out the user name and api values, still doesn’t shorten. Same behavior in two different blogs.

    Happy to try anything else.

    I have the same problem, with all the shortening, except for wordpress. any help?

    This is happening with us as well, specifically for bit.ly and StumbleUpon. All other shorteners work.

    Plugin Author BraveNewCode Inc.



    If you’re still having issues with URL shortening, please make sure you are using the latet version of WordTwit, which ensures compatibility with the latest version of WordPress (3.8.1 currently) and the latest version of Twitter’s API.


    Just tried it again. Still doesn’t work.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Bit.ly shortening not happening with 3.0’ is closed to new replies.
Skip to toolbar