Support » Plugin: qTranslate X » Biographical Info

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Gunu

    (@grafcom)

    Hi Gunu,

    thanks for the prompt reply.
    I doubt that i get the field id of the user.
    I usually go to Users->All Users and scroll down to “About the user” and bellow there is “Biographical Info”. This is what i want to translate. This is does not have an id.

    The URL is then …/de/author/username/ or …/en/author/username/

    Hi, the field has the class “author-description span10” and i tried to add it to the Custom Integration. With and without span10.
    Unfortunately it did not worked.

    Plugin Author Gunu

    (@grafcom)

    @szabadkai,

    I will discuss this with John.

    @gunu
    A short explanation: I am using AMT (Add Meta Tags), a very good plugin.
    It works well with your plugin although the fields from Metadata are not shown as functioning with qTranslateX but inserting text as [:de]xyz[:en]qwe[:] are accepted but just not “highlighted”.
    But “Biographical Info” does not work at all and would be just perfect to make it work too.

    Plugin Author Gunu

    (@grafcom)

    @szabadkai
    see also this topic

    the latest version at GitHub has better integration capabilities. It is possible now to make profile translatable. Try reading Integration Guide on how to do it, although it is a pretty raw draft at this point, but you may hopefully get an idea.

    There is an example file https://github.com/qTranslate-Team/qtranslate-x/blob/master/dev/i18n-config/i18n-config-profile.json, which I was playing with and which may get you started. Front end may need additional filters. That would depend on the theme and where you wish to display those multilingual fields. Let us know how far you could get it.

    In case you need further assistance, please open an issue at GitHub with the step-description of what is needed.

    Plugin Author John Clause

    (@johnclause)

    @szabadkai: I added translation of user meta data. Please, test the latest version from GitHub, which can be downloaded from GitHub page with button “Download ZIP”, or click here for the sake of convenience.

    Thanks John,
    look great. I have now two point where I can not say if they matter.
    1. qTranslate-slug complains that qTranlate-x is not installed but it is.
    2. The User Bio-Info is not marked as translatable and does not show the switching-flag.
    But it works! Good job!

    P.S. I took it from GitHub!

    Plugin Author Gunu

    (@grafcom)

    @szabadkai

    qTranslate-slug complains that qTranlate-x is not installed but it is.

    Check the plugin folder name. Must be qtranslate-x not qtranslate-x-master

    Test qTranslate Slug, at me strange things happen with the latest qTranslate X

    I renamed the original plugin to qtranslate-x.ori. Renamed the new plugin to qtranslate-x.
    The slug works but not the language switch. Although the url is reachable when manually corrected.
    May be something in the db? Is just an idea.

    Plugin Author John Clause

    (@johnclause)

    The User Bio-Info is not marked as translatable

    I assumed you read this:
    https://wordpress.org/support/topic/can-user-profile-info-be-translatable

    We currently do not support -slug (https://qtranslatexteam.wordpress.com/2015/05/15/release-notes-3-4/), since it has never yet been updated to the q-X native schema.

    Hi John, but till before the update of gunu it worked very well!
    With the latest from GitHub it stopped working.

    Plugin Author John Clause

    (@johnclause)

    @szabadkai: What exactly stopped working? Bio-Info was never translatable and you have to use “Custom Configuration” to enable fields that you want to be multilingual, as described in the topic sited. You can also simply use raw language tags in them. Does this help?

    @john: It works well, thanks @gunu. And it works well with qTranslate-Slug. This is not the problem
    Bio-Info is working now. Unfortunately it has always the same title About, which is not right in other language then english.

    The only thing that does not work anymore is the switch in the menu.
    Could you please have a look?
    Thanks
    The test url is: http://youtrust.intra.lynx-consulting.ch/

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Biographical Info’ is closed to new replies.