Support » Plugin: WooCommerce Checkout Manager » Billing is a required field

  • On the checkout page here:
    https://attachplace.com/checkout/

    even though all the required fields are filled out, we are getting this error message: http://awesomescreenshot.com/0275ysvz8c

    Here is the System Report from WooCommerce:

    ### WordPress Environment ###
    
    Home URL: https://attachplace.com
    Site URL: https://attachplace.com
    WC Version: 2.6.1
    Log Directory Writable: ✔
    WP Version: 4.5.2
    WP Multisite: –
    WP Memory Limit: 256 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    
    ### Server Environment ###
    
    Server Info: Apache
    PHP Version: 5.6.22
    PHP Post Max Size: 128 MB
    PHP Time Limit: 120
    PHP Max Input Vars: 3000
    cURL Version: 7.30.0
    OpenSSL/1.0.2h
    
    SUHOSIN Installed: –
    MySQL Version: 5.6.28
    Max Upload Size: 128 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    Zapier Integration - Active Feeds: ✔ 1 active Zapier Feed.
    Zapier Integration - Cron Tasks: ✔ 0 pending Zapier cron tasks.
    Zapier Feed #1 Name: ✔ One Day Attachment- and Trauma-informed Therapeutic Parenting Workshop for Parents and Caregivers
    Zapier Feed #1 Webhook URL: ✔ https://hooks.zapier.com/hooks/catch/1361166/uc2m5p/
    Zapier Feed #1 Trigger: ✔ New Order
    Zapier Feed #1 Test Result: ✔ Successfully sent sample data to https://hooks.zapier.com/hooks/catch/1361166/uc2m5p/.
    
    ### Database ###
    
    WC Database Version: 2.6.1
    :
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    MaxMind GeoIP Database: ✔
    
    ### Active Plugins (21) ###
    
    BackupBuddy: by iThemes – 7.1.4.0
    iThemes Accordion: by iThemes – 1.0.50
    iThemes Security: by iThemes – 5.6.0
    Contact Form 7: by Takayuki Miyoshi – 4.4.2
    Easy Theme and Plugin Upgrades: by Chris Jean – 1.0.4
    Jetpack by WordPress.com: by Automattic – 4.0.4
    PayPal for WooCommerce: by Angell EYE – 1.2.1
    Printful Integration for WooCommerce: by Printful – 1.2.5
    iThemes Slideshow: by iThemes – 3.0.10
    TinyMCE Advanced: by Andrew Ozz – 4.3.10.1
    WooCommerce Product Subtitle: by Varun Sridharan – 2.0
    WooCommerce Checkout Manager: by Visser Labs – 4.0.8
    WooCommerce PayPal Pro: by wp.insider – 1.7
    WooCommerce User Shortcode: by Richard Miles – 1.0
    WooCommerce Zapier Integration: by OM4 – 1.6.0
    WooCommerce: by WooThemes – 2.6.1
    WooThemes Helper: by WooThemes – 1.6.2
    WordPress Importer: by wordpressdotorg – 0.6.1
    Yoast SEO: by Team Yoast – 3.3.1
    Term Management Tools: by scribu – 1.1.4
    YITH WooCommerce Multi-step Checkout: by YITHEMES – 1.3.2
    
    ### Settings ###
    
    Force SSL: ✔
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    
    ### API ###
    
    API Enabled: ✔
    
    ### WC Pages ###
    
    Shop Base: #253 - /shop/
    Cart: #254 - /cart/
    Checkout: #255 - /checkout/
    My Account: #256 - /my-account/
    
    ### Taxonomies ###
    
    Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)
    
    ### Theme ###
    
    Name: Summit - Custom
    Version: 5.1.2
    Author URL: http://ithemes.com/
    Child Theme: ✔
    Parent Theme Name: Summit
    Parent Theme Version: 5.1.2
    Parent Theme Author URL: http://ithemes.com/
    WooCommerce Support: ❌ Not Declared
    
    ### Templates ###
    
    Overrides: –

    https://wordpress.org/plugins/woocommerce-checkout-manager/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Having the same problem after updating WooCommerce.
    Most likely something changed and the plugin hasn’t been updated yet?

    Theme: Statement
    WooCommerce: 2.6.2

    fulmine84

    (@federicanorcini)

    I have the same problem too, after updating woocommerce I am not able to end the order.
    My customers was not able to place orders so I had to deactivate the plugin. It is the only way to complete orders.
    in italiano il messaggio di errore è:
    “di fatturazione è un campo obbligatorio.”
    in English the message was
    “Billing is a required field”

    Same here with the updated version, but I had a backup of an old one, which is working for me without a hassle.

    Uninstall your recent plugin and install this one here -> https://mega.nz/#!2hwUkb5R

    Hope that helps.

    doublekgk thanks, but the link requires a decryption key. Same problem here. I don’t suppose anyone’s figured out a work around other than disabling the plugin?

    Plugin Author Michael Visser

    (@visser)

    Hi gang, can you please confirm if you have a field called “Billing” in your list of Billing fields, I’ve not been able to reproduce this on a new WordPress instance so keen to find out what is causing this.

    Does this happen when you have the default WordPress Theme enabled?

    Yes, I confirm the bug. “Billing” is not in the list of Billing fields. Personally, I added two new fields to the default billing list. Don’t know if this could be the problem.
    Other installed plugin: qTranslate-X (3.4.6.8)
    qTranslate for WooCommerce (v. 1.3)
    Wordpress version: 4.6
    WooCheckout: Version 4.0.9
    Theme enabled: Bluestreet

    Request:
    POST /checkout/?wc-ajax=checkout HTTP/1.1
    Response:
    {"result":"failure","messages":"<ul class=\"woocommerce-error\">\n\t\t\t<li><strong> di fatturazione<\/strong> \u00e8 un campo obbligatorio.<\/li>\n\t<\/ul>\n","refresh":"false","reload":"false"}

    In English: “Billing is a required field”.

    UPDATE: I found the issue: the error shows up because the second field of the Address is required. The same thing happens with the Phone field. It’s optional (in the label) but it’s required in the settings. You should uncheck the “required” checkbox in the settings for the second address field and the phone field.

    Is the fix to drop back to an older version of WooCommerce? Which version works?

    @solsic Thank you!! This fixed it for me.

    I would recommend the plugin author to have those un-checked by default as we never checked those off they were just checked off by default after installing the plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Billing is a required field’ is closed to new replies.