Support » Plugins » Bilingual setup works on one website but not the other?

  • Hi all.

    I don’t know if anybody can help with this, but I thought I’d throw it out there.

    I have 2 sites that are set up very similarly, and on both sites I’m using Transposh and WooCommerce. But the permalinks are making me crazy.

    Transposh works beautifully out of the box on one site. I didn’t have to change anything.

    On the other site, I’ve had to add code, because I would get a 404 when upping the number of items on the Cart page. Now, that is working, but I can’t use the cleaner permalink structure I had before (postname, then default for the WC products). I have to use the clunky default post structure–otherwise, when I switch the site language, all the products disappear. The kicker is, nothing like this happened on the other site. The pre-existing postname structure works just fine.

    I’ve been going back and forth between the two sites, trying to figure out what the difference is. On the non-working site, I noticed the default product structure is called Standard, while on the working site, it’s called Default. Not much else to go on, though.

    Any ideas?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Try to remove/rename woo’s .po/.mo files

    I’m looking for it, but not sure where to look.

    I’m looking under WP Settings>Edit, and WC Settings.

    (I have a single installation-using Child Theme-not WPML.)

    In your file system,

    That would be FTP right?

    I’m not sure if I have access. I’ll have to check into it.

    I finally got in! And I found the WC languages folder.

    Now my question is, do I delete the whole folder, or just the files in it?

    I have woocommerce.pot and woocommerce-admin.pot.

    It’s not .mo/.po exactly, so I wanted to confirm before I did anything.

    Thanks!

    I went ahead and deleted the .pot files in the WC folder via ftp. I’m guessing if it was going to change something on the website, the change would be instant (?)

    It didn’t seem to help, though. When I deleted the files, and switched the permalinks and language, the products all disappeared again. Still searching for an answer. Some articles say increasing php memory might help the issue, but if this problem is not happening on the other site set to the same php limit, I don’t see how I’d need to make that change on this site.

    Only .po/.mo files, not .pot files 😉

    Ok. There were no po/mo files in the language folder, so I must be missing something.

    And another employee just pointed out the “print product” button takes you to a blank page now. I disabled Transposh and tried it, and it worked, but not with Transposh enabled.

    I really want to use this plugin but it seems like my websites don’t want me to.

    Blank pages are probably due to an error, you need to setup a php error log, and echo the relevant lines here.

    I just caught something with the mo/po files.

    I went into FTP of the both site that is working and the site that isn’t. The WooCommerce files are the same (both are .pot).

    However, the site that is NOT working has several mo/po files installed in the WordPress language file. The site that IS working doesn’t have any mo/po files in the WordPress language file–it’s just an empty file.

    If I delete those mo/pos out of the WordPress language file of the broken site, could that maybe fix the permalinks issue?

    Sure, please try, backup those files first, and in the worst case, put them back in.

    I tried renaming them, and no luck. I still had the same issue; whatever this is, it must be really convoluted.

    Working on figuring out the php…

    Ok. I have a php log for one site now (I’m hoping the one site will help me with both).

    There are 14 notices and 2 errors. Here are the errors:

    PHP Fatal error: Call to a member function find() on a non-object in /home/content/p3pnexwpnas05_data03/70/2395070/html/wp-content/plugins/transposh-translation-filter-for-wordpress/core/parser.php on line 712

    PHP Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Bilingual setup works on one website but not the other?’ is closed to new replies.