Support » Fixing WordPress » Big Problem with attempted domain change

  • Hi,
    Serious f**k up today. I tried to change my domain from one name to another. i have both hosted here in the uk by namesco. Not sure what happened, but I had to scrap the idea and try to replace original domains, as I just couldn’t get the change done correctly. Now, http://putneyphysiotherapy.com/wp/ is weirded out! Only this page works and the rest are 404’s. What’s happened? help!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    When I click on one of the links, it takes me to “http://putneyphysiotherapy.com/wordpress/?page_id=861” – notice “/wordpress/” instead of “/wp/”, so the links are incorrect. If I manually change the URL in the browser to “http://putneyphysiotherapy.com/wp/?page_id=861”, it appears to work.

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    Login to the WordPress dashboard, go to Settings > General and make sure that both “WordPress Address” and “Site Address” are set to http://putneyphysiotherapy.com/wp/.

    Error 405 Method Not Allowed

    The requested method POST is not allowed for URL /wordpress/wp-login.php

    Won’t let me in!

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    Ok, this is probably because there is a discrepancy between what the database thinks the folder should be and what the folder actually is.

    There are two ways that we can get this consistent. If you have access to and are comfortable with the database, go to the options table and modify the “siteurl” and “home” options to be “http://putneyphysiotherapy.com/wp/”.

    If you’re not comfortable with the database, the easiest way should be to rename the /wp/ directory to /wordpress/. Then access the dashboard and change the URLs to “http://putneyphysiotherapy.com/wp/” (you will probably get an error after you save, that is ok). Then rename the /wordpress/ directory back to /wp/.

    they were both missing a / at the end….but it now I can’t view the site whichever url I use. My folder structure looks a bit weird. I have a ‘web’ folder at the top with ‘wp’ below. Is this correct?

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    If you want the wordpress site to be at the root of your domain (i.e. http://putneyphysiotherapy.com/) then all of the wordpress files should be in the web folder, not in a “wp” subfolder.

    It shouldn’t matter, but which method for changing the URL did you use?

    Ok, I moved the files into web and now have basic access. Still no control admin though. I changed the url in settings – wordpress address and site address.

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    Any chance you’re comfortable with and have access to the database? It sounds like the setting still hasn’t updated and the surefire way to find out is to look at the database.

    I have it open as we speak

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    There are two fields in the database that you need to check, in the options table – “home” and “siteurl” make sure that those are both “http://putneyphysiotherapy.com/wp/” (my recommendation is to set them then go back to make sure they’re really set – just being paranoid today).

    double checked and correct

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    Hmm… this is where it gets interesting to troubleshoot without seeing the files.

    The next thing I’d look for is an .htaccess file, web, wp, or wp/wp-admin folders. It’s possible that there is something in there causing a redirect.

    Phil Erb

    (@philerb)

    WCUS 2015 Contributor

    I should have noted, if you’re looking at your files with an FTP client, you may not be able to see .htaccess files by default, as they’re hidden. The FTP client probably has an option to show hidden files.

    If you have SSH access to your server, the “ls -la” command will show hidden files.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Big Problem with attempted domain change’ is closed to new replies.