WordPress.org

Forums

Big Problem (5 posts)

  1. Steaps
    Member
    Posted 5 years ago #

    Hi, i'm new here, so sorry if i leave out some required information.

    So a few months back, the website that's hosting my WordPress blog is hacked. They changed around some files, to be honest, I'm not entirely sure what they did, but they killed WordPress. I completely removed the WordPress/ folder from my server (The database hasn't been touched).

    Today I finally get some free time (And memory..) to reinstall WordPress. I reinstall all the necessary files for WordPress, and go to the install.php page. It tells me WordPress is already installed, yada yada yada update the database. Ok, that's done.

    Important Stuff Starts Here

    Now, i go to the login page, and i have forgotten my username and password. I would swear the username was just "admin".

    Anywho, i try using the forgot my password page. I have 3 e-mail addresses, and one of them is the WordPress e-mail address. I enter all 3, and it tells me none of these e-mail addresses are registered to my WordPress, or any accounts with it.

    So i decide to try making a new account. I register, and it all goes through fine, sends me the e-mail to the e-mail address i specified (e-mail address #1, i can login to this account etc. Then i notice on e-mail address #3, i have a new e-mail from WordPress saying a new user has registered on my site.

    Now you see the problem?
    According to the forgot my password page, e-mail address #3 is not registered in any way to my WordPress site. Yet, when i make a new account (using e-mail address #1, my e-mail address #3 gets an e-mail saying that a new user has registered on my site.

    Additional Information:
    The site host is unreliable, and i'm not sure if I can get access to my database (Or know how, for that matter). I have a MySQP Hostname, MySQL Database name, MySQL Username, and MySQL Password. (I'm a software programmer, so i have no idea about MySQL, yet, or how to access it, etc.)

    Any help would be greatly appreciated, and if i could keep my posts (Still located in the database), that would be amazing

    Thanks, Steaps.

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    It's possible that the database was not completely cleaned up after the hack - hence the email address issue. You may need to reset your admin email address in the database using phpMyadmin.

  3. Steaps
    Member
    Posted 5 years ago #

    I will try that, thank you!

  4. Chris_K
    Member
    Posted 5 years ago #

  5. Steaps
    Member
    Posted 5 years ago #

    Since i can't get ahold of the guy to gain access to phpMyadmin, neither of those options work. He'll be getting back to me shortly though, and I can see how this will work. Thanks both of you :).
    (Thread will be updated to resolved once i get it all working)

Topic Closed

This topic has been closed to new replies.

About this Topic