Support » Theme: Wisteria » Big issues with people not being able to post comments

  • Hello,

    I just noticed that if you make a comment that is too long, it forces the “post comment” button down in the white comment box and it then becomes unavailable.

    That box should either increase in size or have a scroll bar so that if your comment gets too long you can still find and press the “post comment” button.

    You can go to this page and try it yourself.

    http://atavisionary.com/child-slaves-mars/

    Just copy and paste some text until the comment is pretty long and you will see that it is not available if it gets too long.

    Please help ASAP

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Alright, I thought of a temporary solution which is kind of ugly and doesn’t really solve the problem, but it does make it substantially less likely for someone to encounter the issue.

    If you add height= 1000px; (or whatever) to the div#respond part of the css document it loads that box a lot larger so a comment would have to be that much larger in order for the error to be seen. Not nice, but that should reduce the problem until a better fix can be found using scroll bars.

    div#respond {
    background: #fff;
    margin: 15px 0 0;
    margin: 0.9375rem 0 0;
    padding: 15px;
    padding: 0.9375rem;
    position: relative;
    height: 1000px;
    }

    Ok, so I played around with it and that did not solve the issue as well as I would have liked. making the comment very long is much less likely to cause the “post comment” button to disappear, though it still happens. That is good, but still there does not seem to be any way to scroll back up to the top of the comment for proof reading etc.

    The comment won’t expand to fill the whole box so 1000px is a bit of overkill. 500-600 is probably enough because the comment form won’t ever take up all of the available space regardless of how much is provided at the start.

    BTW, I am using jetpack comments because it allows users to use accounts from elsewhere to comment so I don’t want to get rid of that to go to native theme commenting.

    I have the latest version of wordpress and have seen this issue on the current version of wisteria as well as the one immediately previous to this version.

    One last thing, I have already tried adding the overflow: scroll; and while it does created scroll bars they never become usable.

    Alright, I figured it out. I had to go into my web host cpanel and edit comments.php.

    for ( var i = 0; i < commentForms.length; i++ ) {
    							commentForms[i].allowTransparency = <?php echo $transparent; ?>;
    							commentForms[i].scrolling = 'yes';
    						}
    I changed scrolling here from "no" to "yes"
    
    I also wanted the height of the box to get a bit longer so:
    
    

    $height = $params[‘comment_registration’] || is_user_logged_in() ? ‘515’ : ‘630’; // Iframe can be shorter if we’re not allowing guest commenting

    I changed 315 to 515 and 430 to 630.

    I am happy with the result, mostly (the “post comment” can still get pushed off the screen, but the scroll bar lets you get to it at least). Hopefully this doesn’t cause any other problems.

    Theme Author wpfriendship

    (@wpfriendship)

    Hi,

    We have tested the comments form and it is working as expected. It shows scrollbar on very long comments.

    I think you have enabled Jetpack Comments and this issue is related to Jetpack comments stylesheet.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Big issues with people not being able to post comments’ is closed to new replies.