Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » between two shortcodes

  • Resolved 972 creative

    (@toddedelman)


    Hi there

    I have an issue when using two shortcodes next to each other.

    I’ve coded them as h3 and h6 respectively and in my visual composer they’re stacked one on top of each other.

    When using the shortcode triggers, we’re getting a line break between them.

    How can we fix this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • To give more context:
    -http://bit.ly/2igkjfA is the page we’re using shortcode triggers
    –backend – http://prntscr.com/gy71l6
    –frontend – http://prntscr.com/gy74fd

    Appreciate the help.

    Hello Todd,

    I just inspected your site url https://kahena.972dev.com/about/ (thank you for including that in the screenshot BTW) and see that VC is passing in a pair of <p></p> tags before and a <br> tag after the shortcode for ‘Ari Nahmani’. My first instinct is to:

    – go into the ‘Text’ tab of the Popup Maker Admin content editor,
    – look for the source of those unwanted HTML elements, and
    – delete them.

    I saw something else about use of the [popup_trigger] shortcode. No need to add a dot before the class attribute passed into the shortcode (e.g. classes=”.team” compared with classes=”team”). Popup Maker does not require the use of the dot.

    Todd,

    Another thought (anticipating a possible response like “but there is no extra set of <p> and <br> tags in my VC content editor”).

    You may need to temporarily deactivate all plugins except Popup Maker and VC. The source of the extra markup may be generated by a plugin add-on to VC.

    • This reply was modified 2 years, 8 months ago by Robert Gadon.

    Thanks for you replies.

    So, in the visual editor, there isn’t any extra code being added. There is however a ‘visual’ line break added each time we save the elements.

    While in theory testing with plugins turned off may work, it’s not a viable solution to have the client turn off plugins every time they want to add a shortcode trigger.

    Any other ideas?

    Hello Todd,

    I nudged the plugin developer, Daniel Iser to respond back to you. Apparently he hasn’t.

    I am only a consultant, not the person managing your site. Therefore, you are at liberty to entirely ignore my recommendations if you wish.

    If I was managing this site, here is what I would do:

    1) If the site is in production, make a clone and move it onto a local developer site for testing.

    2) Attempt to isolate the source of the problem by simplifying the site setup. That begins by deactivating all plugins except Popup Maker.

    3) Examine the front end of the site to determine if the problem resolves. If it does, that indicates that a plugin is responsible for the issue you reported earlier.

    4) Systematically reactivate plugins one-by-one until the problem reoccurs. That would tell me which plugin might be the source of the issue.

    Work systematically and carefully to evaluate possible sources that may contribute to the problem. You are a detective here. Collect data. Systematically eliminate possibilities that may be causing the problem.

    That’s the best advice I can offer without having control of the site myself.

    Plugin Author danieliser

    (@danieliser)

    @toddedelman – If I understand correctly the issue isn’t in Popup Maker or VC. The issue is in WP core. If you are on the text tab and leave an empty line, it automatically turns that into a new paragraph.

    Secondly if your on the Visual tab and press enter it does the same thing. You either need to press Shift+Enter or only one line break in the text tab.

    Third the WP editor visual tab currently doesn’t support inline rendered blocks. Since our shortcodes use rendered blocks to somewhat preview the output rather than a [shortcode] when on the visual tab WP is automatically forcing it on its own line (paragraph). There are only 2 ways around this currently: http://docs.wppopupmaker.com/article/185-why-is-my-shortcode-being-created-on-a-new-line

    Those are about the only options we can provide. The issue isn’t directly in our plugin but in the core editor itself, which is being addressed,hopefully in the next major WP update. The only option to make shortcodes inline is to use the text tab or disable the visual previews & shortcode editor.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘between two shortcodes’ is closed to new replies.