WordPress.org

Forums

iThemes Security (formerly Better WP Security)
Better WP Security removed wp-config.php (11 posts)

  1. José Luis Bolos
    Member
    Posted 4 years ago #

    After installing the plugin and selecting some of the options the plugin left my wp-config.php file completely blank, therefore completely borking my site.

    Even worse, after uninstalling the plugin, the database was left polluted with three tables that weren't removed with the plugin.

  2. José Luis Bolos
    Member
    Posted 4 years ago #

    Wops, I have more info regarding what happened.

    For security reasons I have the wp-config.php file outside the WP directory. When WP can't find wp-config.php, looks for it one directory above. (It's a feature of WP)

    Upon activation of Better WP Security and checking the options the plugin created a blank wp-config.php inside the WP directory. As WP could then find the new wp-config.php first, but were no database options, the site stopped working. After removal of the blank file, everything went back to normal.

    The plugin should check for wp-config.php and not create the file in any case.

  3. sudo
    Member
    Posted 4 years ago #

    Created a blank file automatically , wired, Thx for the headstart...
    :)
    Did you try Jumpple?
    http://wordpress.org/extend/plugins/jumpple

    It doesn't hardening the WP installation but in general they notify you
    when something wrong with your site via mail , Skype Google chat - very cool.
    Josh.

  4. José Luis Bolos
    Member
    Posted 4 years ago #

    It's too bad because the plugin (BWPS) looks really really cool, but I'm scared of trying it again. :(

    sudo thanks for the heads up, I will take a look at it.

  5. sudo
    Member
    Posted 4 years ago #

    No problems!
    :)
    If you have any questions , let me know.

  6. mlmnewsblog
    Member
    Posted 4 years ago #

    Im already in trouble with BWPS, is there any way to resolve this problem

    I got this message " You do not have sufficient permissions to access this page."

  7. José Luis Bolos
    Member
    Posted 4 years ago #

    "is there any way to resolve this problem"

    What problem?

    If you can't access your site because your wp-config.php is borked, you should restore it from a backup. (You do have a backup, do you?)

    If you installed a plugin and the plugin itself is preventing you from accessing the site, you can try disabling all the plugins modifying the database. First two google results:
    http://perishablepress.com/press/2008/02/18/quickly-disable-or-enable-all-wordpress-plugins-via-the-database/
    http://kb.siteground.com/article/How_to_disable_all_WordPress_plugins_directly_from_database.html

    Can't be of any much more help since you don't specify what the problem actually is.

  8. mlmnewsblog
    Member
    Posted 4 years ago #

    Please click here to see the whole problem,

    The above link will give you the whole idea what problem im facing.

    thanks...

  9. José Luis Bolos
    Member
    Posted 4 years ago #

    Oh, Ok, I see. I'm sorry but your problem has nothing to do with what happened on this thread. Glad that you already have a solution.

  10. ArcadeFunhouse
    Member
    Posted 3 years ago #

    Hello I installed Better WP Security Plugin on my Arcade site. After Activating the Plugin, it recommended I change a few things. I followed the first suggestion and then I was locked out of my site.

    “You do not have sufficient permissions to access this page” I can’t even get to my dashboard anymore. The change I made was something about changing the name of my folders from wp. After I ran the suggestions, it said I didn’t have the proper tables installed and then it was just stuck and so I followed the steps explained below.

    I tried to uninstall it but it wouldn’t uninstall, I deleted the folder via FTP and it’s still securing my site. I don’t know what happened, but this is unreal. Could you please help me recover my site?

  11. mlmnewsblog
    Member
    Posted 3 years ago #

    @ArcadeFunhouse, I hope this will help you...

    Your host ran out of memory during the renaming operation.

    To fix it, go into the database itself and find the "usermeta" table. look for the "wp_capabilities" row for your user and change wp_ to your table prefix.

    Then in the option table find the row "wp_user_roles" and also change wp to your table prefix.

    See if this helps you...

    I got this solution for the maker of this plugin...

    Ak Sharma

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic