Support » Plugin: iThemes Security (formerly Better WP Security) » Better WP Security no longer emails file changes

Viewing 11 replies - 1 through 11 (of 11 total)
  • Please double check and try re-saving the settings for “Intrusion Detection”

    Yes, I already did that, but I’ll try it again.

    OK. Thanks. The next question I have to ask is if the emails are either in your spam folder or not being sent? Do you have access to the server logs that might verify whether the emails are being sent or not?

    No, they’re not in the spam filter; I don’t get any spam, so I treat that as an alternate inbox. BTW, prior to this latest release where I am now getting no emails, before I would routinely get 4 or 5 copies of the same one simultaneously.

    The logs I was able to look at just now make no mention of email traffic one way or the other, so I don’t really know.

    Thanks. The previous bug was solved and I am getting emails on all the sites I’m running. Let me take a look and see if I can’t try to recreate the bug.

    Ah, sorry to have bothered you, Chris. After some extensive digging it turned out my host had blocked a particular email domain, a problem which I think I’ve solved. Again, thanks for your prompt attention and for putting me on what turned out to be the right track.

    Glad it’s working. Which host do you have? This is the 3rd time this week I’ve seen this issue.


    The problem was caused by this email policy change:

    “If you are currently sending as one of the above domains via your DreamHost email user you will need to update your mail client settings to send as your proper domain email address. If you do wish to send as one of the prohibited domains (such as Gmail) you will need to configure that email account through the proper email server on your computer/device.”

    The solution is either to use a host-authenticated email address and the basic php mail function or to configure your prohibited domain to use SMTP and then use the wp-mail-smtp plugin

    also configured for SMTP.

    It’s reasonable to assume other hosts have taken similar measures without detailing the consequences for dependent programs.

    Great (sigh)

    Thanks for the update. Sounds like this could be an issue for a number of folks.

    I have this issue with dreamhost as well. The WP Mail SMTP plugin worked to fix this for me. Although it’s worth noting that on the first day my WP site was up with dreamhost, I experienced an email delay of 3-6 hours. Emails were completely erratic the first day my site was up and running. So I would recommend waiting 24 hours after site install to even BOTHER trying to fix these issues if you are dealing with a fresh install. Because the email delay will keep you from knowing if it worked! See note from dreamhost customer support.

    This is related to our SPAM prevention policy. It states that the FROM
    address in any form must be an email on the same domain. For example, something like

    You can view all bounced emails in your FTP account. Once logged in under your username, click in the the folder /Maildir/new. Here you’ll be able to open your messages and see the errors reported as to why they were not delivered.

    No emails are getting sent to me. I’m on

    I guess I’ll look into trying WP Mail SMTP and see if that helps…

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Better WP Security no longer emails file changes’ is closed to new replies.