iThemes Security (formerly Better WP Security)
[resolved] Better WP Security & Jetpack Comments (10 posts)

  1. macleanwalker
    Posted 3 years ago #


    Great plugin, thank you for all your efforts.

    My site was working fine before I installed the plugin. Howver after installing it when a user tried to post a comment on a blog post they got a 404 message. I disabled BWPS and it worked again. After some fiddling around I discovered that if I disable the JetPack Comments function then it reverts to traditional comments and it all works.

    It appears that there is some .htaccess config in BWPS that conflicts with Jetpack Comments - any ideas as to which setting I shopuld toggle on/off

    My site is http://datamgmt.com

    Thank you


  2. Not sure yet... My hunch is, from a quick glance, that it is a conflict with hide backend. I will take a look and see what I can figure out.

  3. macleanwalker
    Posted 3 years ago #

    Thanks, if you want me to try anything here just let me know

  4. Thanks. Admittedly this will probably take me a few days before I can investigate. I'll post back when I have a patch.


  5. I do believe I have a working fix (at least it works on the 2 sites I could test Jetpack comments on)... Please try the dev version (http://downloads.wordpress.org/plugin/better-wp-security.zip) and let me know if it works for you.

  6. macleanwalker
    Posted 3 years ago #

    Tried it with the same 404 result - sorry

  7. Hmm....

    ...I tried a couple of other fixes in the 3.4.1 version I've just released. Please try it and re-save your "System Tweaks" settings after you upgrade. I just realized that without any database updates it probably didn't rewrite your .htaccess. If it still doesn't work disable "Filter Spam Comments" in System Tweaks and I'll go back to the drawing board.

  8. macleanwalker
    Posted 3 years ago #

    That worked - I've used the dev release you provided this morning - should I now upgrade to 3.4.1?

  9. Yes, please upgrade. 3.4.1 are just the official push of that fix and a couple others.

  10. meshmarketer
    Posted 3 years ago #

    I had the same problem after installing. I had the basic settings plus changed permissions for all the recommended files, turned on all "white" tweaks (no "yellow" tweaks) and had this problem. I've just installed the plugin so it's the most recent version.

    Better WP Build Version: 3054

    I plan to buy the pro version because it's a really good bargain, but I really need to figure this out.

    I restored backup of files and still have this on, but nothing further.

    Am using MultiInstall.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.