WordPress.org

Forums

iThemes Security (formerly Better WP Security)
Better-wp-security generating wrong .htaccess (3 posts)

  1. Rarok
    Member
    Posted 1 year ago #

    Better WP Build is 3064
    Version is VersiĆ³n 3.6.2
    Wordpress is 3.8

    The site stoped working and it just gave a 500 Error.

    Don't know much about the .htaccess file but the trouble seems to be there.

    Wp-Secutiry is writing this

    # BEGIN Better WP Security
    Order Allow,Deny
    Deny from env=DenyAccess
    Allow from all
    SetEnvIF REMOTE_ADDR "^5\.248\.84\.12$" DenyAccess
    SetEnvIF X-FORWARDED-FOR "^5\.248\.84\.12$" DenyAccess
    SetEnvIF X-CLUSTER-CLIENT-IP "^5\.248\.84\.12$" DenyAccess
    <IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} ^(.*)wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !^(.*)websitename.com.*
    RewriteCond %{HTTP_REFERER} !^http://jetpack\.wordpress\.com/jetpack-comment/ [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule ^(.*)$ - [F,L]

    </IfModule>
    # END Better WP Security

    By trying I found that deleting the part that says this

    Order Allow,Deny
    Deny from env=DenyAccess
    Allow from all
    SetEnvIF REMOTE_ADDR "^5\.248\.84\.12$" DenyAccess
    SetEnvIF X-FORWARDED-FOR "^5\.248\.84\.12$" DenyAccess
    SetEnvIF X-CLUSTER-CLIENT-IP "^5\.248\.84\.12$" DenyAccess

    Just gets the website working, but it keeps writing the same. Why?

    http://wordpress.org/plugins/better-wp-security/

  2. Rarok
    Member
    Posted 1 year ago #

    More information. The file error.log has this message:

    " .htaccess: order not allowed here"

  3. supawiz6991
    Member
    Posted 1 year ago #

    very interesting.... have you tried disabling wpbs by renaming its plugin folder?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.