Support » Plugin: iThemes Security (formerly Better WP Security) » Better WP Security 3.4.10 Update – 500 Internal Server Error

Viewing 15 replies - 1 through 15 (of 16 total)
  • I had to delete the plugin and the .htaccess and then reinstall the plugin.



    jfees, did it work?

    I also met with 500 Internal Server Error

    I droped 2 tables in MySQL database. “.htaccess” file I’ve labeled as “.htaccess.old“. Then I put the default “.htaccess” file.

    I’ve deleted installation folder (v3.4.10). Then I went back to version v3.4.8. This version I use on several websites. With the old version does not have any problems.

    Of course, this works (v3.4.8).

    I do not want to go to a newer version, while the author does not solve problems.

    However, all this is what I wrote before unsuccessfully. No need to try to go back to the old version. To make it work I had to do the following:

    Open wp-config.php

    At the top, delete the line that puts BWPS. Leave it just like the original:

    * The base configurations of the WordPress.

    You will now be able to access the page and the control panel. But the problem does not happen again to do the following:

    Go to Tweaks > Other Tweaks. At the bottom of the page. The first checkbox is turned on. Everything else off.
    Save Changes.

    Now you can upgrade your version if you wish.

    16. Better WP Security is not allowed to write to wp-config.php and .htaccess. Click here to fix.

    This (v3.4.10) will get you into trouble.

    My entire website just completely blew apart after upgrading. What a complete mess. Will re-install both database and site from backups and then delete BWPS immediately.


    Trying to solve the problem by my instructions. You can always delete this plugin. But it is better to have at least some protection than none. Notify us of the result.

    In the meantime, let’s hope that the author will solve these problems.

    I didn’t even get a 505. I had a complete site breakdown. Your solution wouldn’t help, unfortunately.
    I agree security is important. But BWPS’s frequent upgrades are just too fragile and not tested well enough.

    Hi folks,

    I have the same issue.

    Cpanel Error Log reports “[Sun Apr 21 13:46:51 2013] [alert] [client ***.***.**.***] /home/*******/public_html/.htaccess: </IfModule> without matching <IfModule> section”.

    I already tried to follow vipteam’s instructions but nothing happened.

    Maybe somthing wrong with .htaccess code, but I don’t know how to solve.

    What do you have in the first five lines in “wp-config.php”?
    I’ll try to help you.

    I have

    * The base configurations of the WordPress.

    Thank you for helping me.

    OK. That’s fine. You followed my instructions. Now try the following. Deactivate plugin. If you can not, connect to the FTP.

    Go to “wp-content” > “plugins”
    Before the “better-wp-security” write anything. Eg. “## ## better-wp-security”.
    It will instantly deactivate the plugin.
    In the wordpress installation folder “.htaccess” rename to “.htaccess.old”
    Instead it put the original “.htaccess” file that WP puts as default.

    Now you should be able to access the control panel and the entire page.

    Let us know here if you solve the problem.

    I had the same problems. I tired to restore the plugin and my .htacess. I can get into the site but I still have problems. I ended up disabling the plugin for now. I really hope this is fixed soon.

    We have to wait. The author will, I believe, quickly solve the problem and launch a new version.

    I followed your last instruction too, but now I have “Fatal error: Call to undefined function wp() in /home/******/public_html/wp-blog-header.php on line 14”

    I inserted the following code in a new .htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Is it correct?

    However, I disabled all plugins, but nothing happened.

    That is correct. I’m not sure what happened on your side. Have you perhaps changed the prefix in MySQL? Through BWPS? Check it out. If you activated the plugin, please follow the instructions above to Tweak.

    If you do everything according to my instructions, you will not solve the problem plugin. But now you will not be able to use a normal page (when the plugin is disabled).

    Does the author know about our problems here? Maybe we should report the problem to the Plugin Homepage.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Better WP Security 3.4.10 Update – 500 Internal Server Error’ is closed to new replies.