WordPress.org

Support

Support » Alpha/Beta » [Resolved] Beta tester plug-in downgraded my version?

[Resolved] Beta tester plug-in downgraded my version?

  • Alright… so I was silly. And I didn’t do my backup before I upgraded. I’ve never had a problem before. I’ve been running 3.0-beta1 for a bit. I just got the beta tester plug-in and used it to upgrade but it downgraded me to a development version of 2.9.2? Anyone else have this problem or was that just me? And how do I re-upgrade? I was running a multisite and I don’t know what that is going to do to the second blog I had. Thank goodness I have an export file of all my posts.

Viewing 15 replies - 1 through 15 (of 15 total)
  • This happened to me too (on a single site though). It does that if you selected “Point release nightlies”.
    You have to select “Bleeding edge nightlies” to stay in the 3.0-beta branche. Also to re-upgrade.
    That is … assuming it works the same on a single site as on a multi-site…

    Moderator Peter Westwood

    @westi

    WordPress Lead Developer

    Yes this definitely sounds like what would happen if you had the default settings in the plugin.

    I think I can improve on that though and make it more obvious you are going to downgrade.

    Will add improvements in this area in a future version of the plugin.

    Moderator Peter Westwood

    @westi

    WordPress Lead Developer

    I’ve added a warning for this scenario in version 0.90 of the plugin.

    i’ve got ‘Bleeding edge nightlies’ selected (as i had before i upgraded the plugin to version 0.90) but it still states ‘Your current WordPress Beta Tester plugin configuration will downgrade your install to a previous version – Please reconfigure it.’ on the upgrade screen.
    not going to touch it as 3.0-beta1 seems stable and i don’t want to downgrade.
    any advice. should i downgrade and then upgrade?

    I had the same thing as lupinehorror. As i have it running on latest site i just did the upgrade and it did upgrade me so there seems to be an error with the alert

    I have the same message in 0.90 “Error: Your current WordPress Beta Tester plugin configuration will downgrade your install to a previous version – Please reconfigure it.”

    Same here, no matter what i do the message still there, i assume there should be an upgrade to fix this in a short while.

    Moderator Peter Westwood

    @westi

    WordPress Lead Developer

    Sorry – I did test this before pushing it out this morning but seem to have introduced a bug.

    Working on a fix

    Moderator Peter Westwood

    @westi

    WordPress Lead Developer

    Fix will be available soon as v0.91.

    That’s cool, Thanks Westi!

    I came here looking for similar reports before risking the “update core”, so I’m glad I found this.

    Just updated and upgraded and all seems to have gone smoothly.

    yup…all sorted. thanks for the quick fix.

    Westi, unfortunately, even though I’m using the v0.91 of your plugin, I’m not seeing the update button in Tools. All I see is the option to update the core, which would bring me back to 2.9.2. I’ve got Bleeding edge nightlies checked.

    I just discovered something: If I click on the Dashboard button so it opens, I see Updates. Clicking on that produced:
    An updated version of WordPress is available

    You are using a development version of WordPress. You can update to the latest nightly build automatically or download the nightly build and install it manually:

    and two options: Update automatically and Download nightly build. With some trepidation, I cliked Update automatically, which worked. I’m not at 3.0-beta2-14860. I’m not sure the plugin is necessary.

    Moderator Peter Westwood

    @westi

    WordPress Lead Developer

    @paulaeisenberg: Yes the updater moves to a dashboard sub menu from tools in 3.0

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Beta tester plug-in downgraded my version?’ is closed to new replies.