begin with www or not? (5 posts)

  1. rebecca@uesjournal.com
    Posted 8 years ago #

    Hi. I have my own domain and recently installed wordpress. In the settings area I chose the location to start with http://www.rebeccaschiffman.com so now if i type just http://rebeccaschiffman.com i get this error message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/rebeccas/www/www/index.php:1) in /home/rebeccas/www/www/blogsite/wp-includes/pluggable.php on line 689

    Is there a way to just make it redirect to www?

    Thank you,

  2. iridiax
    Posted 8 years ago #

    Are you using any plugins or custom .htaccess rewrites? If these aren't at fault, you should contact your webhost about this problem.

  3. rebecca@uesjournal.com
    Posted 8 years ago #

    Hi iridiax,
    I am using some plugins. This is what my .htaccess file says- does this look ok?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blogsite/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blogsite/index.php [L]

    # END WordPress

  4. RosieMBanks
    Posted 8 years ago #

    Read this:

    "How do I solve the Headers already sent warning problem?"

    Oops... edited to add I misread the original post. Sorry!

    There is this plugin, but actually, it does the opposite of what you want.

    I think I'll just go stand in that corner, over there.

    Wait a minute... you've got a double "www". Did you accidentally duplicate "www" in your settings panel?

  5. iridiax
    Posted 8 years ago #

    Your .htaccess file looks fine. Try disabling your plugins and see if the problem remains. And as Rosie suggested, check your settings panel. If none of these work, contact your webhost.

Topic Closed

This topic has been closed to new replies.

About this Topic