Support » Plugin: SVG Support » Beaver Builder – SVG not showing inline

  • Resolved schmekis

    (@johnmecham)


    I created an svg “infographic” using Inkscape and would like the SEO benefit that an svg can give vs. other image formats.

    If I’m not mistaken, that is only possible if the svg is inline?

    I have spent an hour reading others’ support tickets where they needed help getting an svg to appear inline. I’ve got the settings correct, and am not using any conflicting JS minification plugins. I’m at a loss.

    Was hoping I wouldn’t have to bother you, but wondered if you will take a look at the webpage I included, and tell me what I need to do to make the svg inline?

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Benbodhi

    (@benbodhi)

    Hi there,

    It looks like you have something making the image lazy loaded, which means it will load too late for my plugin JS to switch it out for the inline SVG code.

    Depending on how the lazy loading is set up on your site, this may or may not work:
    https://wordpress.org/support/topic/lazy-loading-fix/

    If using the loading eager attribute doesn’t work, then you must have a plugin or your theme lazy loading the image and there should be a way to make sure that one in particular isn’t lazy loaded.

    It looks like you may have it in an image element of the builder? It’s best to just put the tag directly into a plain code/text element, so the builder’s image attributes aren’t applied.

    Let me know how you go. Happy to help you get it working 🙂

    Plugin Author Benbodhi

    (@benbodhi)

    How did you go with this?

    Plugin Author Benbodhi

    (@benbodhi)

    In addition to this, WordPress has now included Lazy Loading by default. So removing that may help too.

    Just add this to your child theme’s functions.php file:

    // Disable WordPress Lazy Load
    add_filter( 'wp_lazy_loading_enabled', '__return_false' );
    
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.