Support » Plugin: WooCommerce Multilingual - run WooCommerce with WPML » Beaking Woocommerce API REST

  • esquipulas

    (@esquipulas)



    After last update the plugin is breaking data transmission via WooCommerce API using the POST method : data is not saved. Deactivating the plugin all is fine. How can I get help ? This is a serious problem and would like to solve it quickly.

Viewing 6 replies - 1 through 6 (of 6 total)
  • esquipulas

    (@esquipulas)

    Extra info : the problem is since version 4.2.1 which, by the way, affect the API REST.

    Downgrading to 4.2.0 it is solved.

    Plugin Support George Botsev

    (@botzev)

    Hello,
    Could you please give an example of the problem.
    I need to test that and reproduce the problem in order for us to debug it and anything is helpfull.

    esquipulas

    (@esquipulas)

    Hello,

    You can look the video here

    And check the difference when version 4.2.0 is unabled and yet not 4.2.1 on this other video

    FYI just posted also on the support forum of WPML there.

    Plugin Author Andreas Panag

    (@andrewp-2)

    Hello @esquipulas and thank you for your reply.

    I tried to replicate the issue but I cannot.

    Steps I followed :

    – Created a product with REST
    – Updated the info (SKU, regular price, sales price, dimensions) with REST
    – Updated many times the product with different data with REST

    Everything updated correctly.

    I tried this with the official library of WooCommerce (https://packagist.org/packages/automattic/woocommerce). Also I tried to use the software you are using in your video without any problem either. Please check my image bellow :

    https://imgur.com/a/0cM9c

    As you can see I was able to update a product with the info you said. I am using latest wcml (4.2.4) and wc 3.1.2.

    Can you please try one more time and create a new product and the try to update it?

    Also please change in your software the authentication type from Basic to OAuth 1.0. Just add the keys there, Select Encode OAuth Signature, Select HMAC-SHA256 in Signature Method and Save.

    Try now one more time to Update the product.

    If if doesn’t work please provide us more details about what are you doing so we can reproduce the issue.

    Thank you very much.

    esquipulas

    (@esquipulas)

    H Andreas thanks for reply and sorry for delay, didn’t got follow up notifications of the topic.

    Very strange you couldn’t replicate the issue.

    The truth : I’m not very comfortable to update again to 4.2.4 for now, I loose a lot of time since the issue and do not want take the risk to erase again datas (was an update of 28 products I had to make manually after deleting each one and each translation … very very boring).

    I sent your answer to woocommerce support which first was contacted to identify the issue, waiting for their answer, and also ask to the dev who build the sync system to read it and make me a feedback.

    I’ll make the changes you suggest (auth type) and let you know what happens.

    Once these things achieved (getting feedback of woo support + sync system dev + changing auth type) I’ll test again and tell you what happens.

    Thanks again,

    Eric

    Plugin Author Andreas Panag

    (@andrewp-2)

    Thank you for your reply.

    In general it is a good move to take a backup before doing any updates in our like site. You can use plugins from wp repo which can help you with it.

    Also there are no bug differences in 4.2.0 and 4.2.4 but if you upgrade to the upcoming WooCoomerce 3.2 you should update to the latest version of wcml.

    Also I think it is a good option to check the bridge but the Developer you built it. If he find something feel free to add this information here so we can test it. But have in mind that we are not supporting custom solutions or 3rd part software.

    Looking forward for your reply when you have news.

    Thank you very much.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Beaking Woocommerce API REST’ is closed to new replies.