Support » Plugin: SLP Payments for WooCommerce » BCH orders stay in pending payment status after payment is made by customer

  • Resolved keepbitcoinfree


    SLP payments & updates seem to be working fine. I had a customer pay with BCH though and the order has stayed in “pending payment” even after payment was made.

    I tested it myself as well. Nothing updates on the page after checkout or after multiple confirmations. Everything else works fine, the addresses are generated & funds are received, SLP payments update the page fine and are recognized but BCH doesn’t. I have to manually update the order to processing for BCH payments to push them forward right now.

    Example –
    A test order (paid with BCH) generated this address:

    I sent BCH to the address & it was received by my wallet, all good there. The page after checkout never updates though, still says pending and the order itself stays at ‘pending payment’ indefinitely until I update it.

    On the checkout page waiting for payment, it shows two errors as well:

    HTTP: Invalid HTTP response code 404 on GET:

    {“timestamp”:”2020-03-31T23:41:56.224+0000″,”status”:404,”error”:”Not Found”,”message”:”No message available”,”path”:”/v2/slp/balance/simpleledger:qphxsrmnp22gn0xem3yhut3scm282jfv0q83fk8gnh/”}

    Inside the order, the bchAmountReceived attribute stays at 0. For BCH Blockchain API, it is set to the default,, which appears to be working.

    WordPress 5.3.2 running Twenty Seventeen theme.
    SLP Payments for WooCommerce – Version 1.2.37
    WooCommerce – Version 4.0.1

    Let me know any other information you may need.


    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor ekliptor


    Seems it’s classified as the wrong payment type (SLP instead of BCH).
    Can you please make a screenshot of the Order page in WP Admin of such a failed order?I am only interested in the “custom field” values at the bottom, not customer address etc at the top.

    Plugin Contributor ekliptor


    Also please try a NEW ORDER with the just released v1.2.38 to see if the problem persists.

    Thanks for the help. Here is the screenshot –

    I’m looking into updating the plug-in to the latest and testing it out.


    Same issue after updating to latest ‘SLP payments for woocommerce’ so far. Created new order to be paid with BCH & then made payment. Checkout/payment page still showing pending and the order within WooCommerce is also showing pending and not updating automatically.

    also showing these errors again:
    HTTP: Invalid HTTP response code 404 on GET:

    {“timestamp”:”2020-04-01T17:16:57.668+0000″,”status”:404,”error”:”Not Found”,”message”:”No message available”,”path”:”/v2/slp/balance/simpleledger:qp3qrmlwdl6hgjxgq0c0jlqxzue3snl7zv8yk4amyg/”}

    I could try updating wordpress to the latest (v5.4) from current (v5.3.2) as well.

    Actually, it looks like the new BCH order did eventually go through. It just took an hour or so. I double checked & 0-conf was enabled but I’m just glad it’s working. Thanks!

    Plugin Contributor ekliptor


    According to you screenshot the payment was properly classified as a “BCH payment” (slpPayment 0). I improved the check for SLP/BCH, so now he should always use the correct address.

    Please update to version 1.2.39 and try again.

    Currently 0-conf is only “instant” for SLP payments because we have a faster API server to check for those. We will switch to a faster BCH server to check for payments later.

    Plugin Contributor ekliptor


    Closing as resolved. If you have further issues please open a new Ticket.
    And yes the plugin is compatible with WordPress 5.4

    Thanks for your help with this ekliptor. Everything is working as expected now, BCH orders are correctly processed in time & SLP orders are confirmed & processed instantly. I appreciate your help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘BCH orders stay in pending payment status after payment is made by customer’ is closed to new replies.