WordPress.org

Support

Support » Plugins and Hacks » Batch Categories plugin not working with WP 2.5.1

Batch Categories plugin not working with WP 2.5.1

Viewing 7 replies - 1 through 7 (of 7 total)
  • Nobody using it with 2.5.1?

    dariusofthedark
    Member

    @dariusofthedark

    It didn’t work in 2.5 for me either…the interface is kind of mangled…I even tried the most recent one from the subversion server, nothing.

    ladydelaluna
    Member

    @ladydelaluna

    I’m running into issues with it telling me that there are no posts in a category when my manage->categories tab says there’s like 20. I’m not sure why it’s only doing it for certain categories and not all or none, but it’s really frustrating!

    I’m using 2.5.1 and it’s not that I’m having the problem you’re having, but a different one that I can’t find help with. 🙁

    TheWebHead
    Member

    @thewebhead

    It doesn’t work for me in 2.6. You try to change 15 posts at once and it says it changed one when it didn’t.

    youknowyourself
    Member

    @youknowyourself

    Hi folks,

    I too had this problem with the whole “Sorry can’t find any posts” when there were a 100 in the category.

    For me the problem came down to sub categories that were longer than one word which made me create a slug with a hyphen in it. This is what seemed to break it. As long as you make sure all your category slugs are one word everything still seems to work.

    There must be an odd string replace in the code somewhere or something… but the solution for me is to just change my slugs.

    Hope that helps!
    Version 2.5.1

    yeah it doesnt seem to work with the latest version of wordpress

    I’m on version 2.7.1, and I’m experiencing something similar. If a category name or a tag name has a space in it, I don’t get any filter results. For me, a slug with a hyphen is no problem at all, but if the actual name has spaces, I get no results.

    I worked around this. I just temporarily renamed the categories and tags that I wanted to work with. I put hyphens in place of the spaces. Then after I was done, I removed the hyphens. It worked like a charm.

    Another issue was that I couldn’t see pagination. Firebug confirmed that the pagination was there; I just couldn’t see it. So I fixed that issue by changing the styles in the batch-category plugin files.

    Caveat: This was a trial-and-error effort on my part. I don’t really know if everything I did was necessary, but now that I can see the pagination, I’m not touching it!

    First, I opened admin.php and replaced all instances of

    tablenav

    with

    tablenav-batch

    Then I replaced the instance of

    tablenav-pages

    with

    tablenav-pages-batch

    Then I opened admin.css and added the following:

    .tablenav-batch .tablenav-pages-batch {
    	cursor:default;
    	display:block;
    	float:right;
    	font-size:11px;
    	height:30px;
    	color:#555555;
    }

    The pagination still looks a little funky, but at least I can see and use it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Batch Categories plugin not working with WP 2.5.1’ is closed to new replies.