Batcache casuses Segfaults (3 posts)

  1. Scott McMillan
    Posted 5 years ago #

    I added Batcache was running fine on a few pages then stopped working (showing the cache status before head). Memcache server was up so no issues there. Also started filling logs with segfaults. I removed Batcache and segfaults disappeared. Anyone else experience this?

  2. al_dantas
    Posted 5 years ago #

    I have the same problem here. I figured that it will happen when I try to open any subdomain that doesn't exist on my wordpress network.

    Lets say I have a.example.com b.example.co and c.example.co set up if I try to access anything.example.com beside those a/b/c I get a white page on the browser and in the Apache's log:

    [notice] child pid 18019 exit signal Segmentation fault (11)
    zend_mm_heap corrupted

    That won't happen if I am logged in the backend. I basically don't get any response from apache and I am not sure what to do in order to troubleshoot that... I tried pretty much everything here...

    Does anyone have a clue?


  3. al_dantas
    Posted 5 years ago #

    I ran a backtrace on a apache's core dump and I figured that the problem was with pecl memcache php module that I was running. I just installed the latest version and the segment faults stopped.

    Here is what I have now: CentOS Base Php 5.3.3 and memcache-3.0.6.tgz from: http://pecl.php.net/package/memcache

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Batcache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic