Support » Plugins and Hacks » BAStats Error

  • Hi…can someone please help me, I have no idea what I am doing wrong. I uploaded all the files into my plug-in folder…and on the front of my blog..this is on top of the header:

    Warning: in_array(): Wrong datatype for second argument in /www/a/andrena/htdocs/public_html/wp-content/plugins/BAStats_logger.php on line 114

Viewing 7 replies - 1 through 7 (of 7 total)
  • Oh….I forgot to say “thank you”! 🙂

    Hmmm..I just got the same error as well. =/ I’m not sure why, being that it’s *been* working on my main blog, running 2.0.4-alpha..and haven’t seen that error there.

    I just installed this again, on another domain, and now it’s showing. =/ I’ll try a few things once..see what happens. =)


    Damn..still no luck, removed the plugin from the plugin folder, reuploaded it, activated change. I’m wondering if it’s because of “temporary” subdomain name that’s mirroring for regular domain. =/ Which I don’t need now, since the main domain is working.. =p

    I dunno..maybe it’s just the new host haha..


    Ah well..fluck it! I’ll just DELETE ALL and start fresh! SIGH!..gerd damn things! I have *all* the time in the world anyways..lmao! I also deleted that damn subdomain name now, hopefully something works on this new host!


    Damn! I can’t for the life of me, figure out why it’s doing that above error, on the new domain, but not the V.B. one. They are both running the same version of WordPress. =/

    I’m seriously thinking it *is* the host, or something. =/ Fuggin lol!


    Ah, I think I found the problem now.. I’ve been running PHP 4.4.2 on the V.B. blog, where I was running 5.1.2 on Now that I switched back to 4.4.2, the error is still there lmao!
    Someone on the testers list said this:

    “That’s from PHP5. You’ll need to cast to array or otherwise make sure the second argument to in_array() is an array.

    Of course, I’m at a loss, even after reading that page they gave me lol! Especially when Line 114 is a DB query part..

    $sdata = $wpdb->get_row("SELECT * FROM {$wpdb->visitors}, {$wpdb->refer}, {$wpdb->ua}, {$wpdb->os} WHERE visit_id = {$sid} AND referer = referer_id AND osystem = os_id AND useragent = ua_id");

    Anyone have any idea how to cast to array, or make sure the second argument to in_array() is an array? I’m at all loss sigh.. thanks in advanced.


    Me got it taken care of now lol! Rather then waiting on someone to possibly help, or fix it myself.. I did a quick search, yeah..[slaps self]..because I tell ppl to do so, but then I didn’t right off the bat lmao..

    But, found this for those that might need it too. 😉


    Also, some props goes to: phil over at, for trying to help me as well. Yes, I have connections and help from almost every wheres lol!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘BAStats Error’ is closed to new replies.