Support » Plugins » BAStats & Host IP

  • I Upgraded to WP 1.5.1 and latest BAStats. Everything seems to work except now I’m getting numerous instances of Host IP in my stats.

    Any ideas?

    Any help would be appreciated.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You can check yourself by using services such as whois and type in the above IP number and search.

    If they show up a lot, they are often “you” or something to do with what you are doing, or possibly spammers or search engine bots.

    spammers wouldn’t use an IP address of 255 – class d is usually reserved and not available to the public. Seems more like host thing, as 255 is a broadcast address. could be wrong though. talk to your host and ask em, but it should be ok is a special IP, the “limited broadcast address”. It shouldn’t ever be routed on the Internet, so a whois query won’t help.

    Someone on your server’s local network is probably causing this.

    Has no one else seen this behavior? I didn’t see this until I upgraded as I mentioned.

    After some cross checking I am thinking maybe this is a BAStats issue. Where BAStats records, my raw access logs and CGRef have real IP addresses. I don’t think they are on my network.

    Example: and show up in CGRef and raw access logs, but show up as in BAStats. My server is at

    Did anyone ever figure out a solution to this problem.? I also get tons of since upgrading to 1.5.1.

    hmm it’s very odd that aplugin would be using a broadcast address – have you guys tried contacting the plugin author, assuming you all use it, it might be worth contacting the author and finding out what’s what.

    sbfsb40, or anyone else,

    Is it possible that the problem is related to our hosting company? I use Dreamhost. It’s a very weird bug. Half of my hosts on the stats page are I did post on the plugin author’s site, but no response yet.

    This looks like a plugin problem to me. I think your best bet would be to either diff between the two versions of the plugin or searh for that special IP in the code or best to make efforts to contact the author.

    PHP’s ip2long likes to return signed long values. If your IP equates to a negative value, MySQL ends up storing a number that equates to something like “”.
    MySQL has two internal functions INET_ATON and INET_NTOA to work around this. In the BAStats_logger.php file, change line 92 to….

    $qry .= “INET_ATON(‘” . $_SERVER[‘REMOTE_ADDR’] . “‘)”;

    … and the problem should go away.

    Moderator James Huff


    Volunteer Moderator 🚀

    Make sure that you’re using the latest version of the plugin (v1.0 beta; build 8):

    i am having the same problem. the fix posted above by changing line 92 didnt seem to do anything.

    i used the old version of bastats when i had WP 1.5 installed. after the upgrade to 1.5.1, bastats stopped working, so i removed it. after reading that a new beta build was out, i decided to give it a try again. the old version of bastats (with WP 1.5) displayed the IP just fine, but now with this new version all IPs are logged as i am curious why if it is a host issue, that it worked fine before…


    The suggested edit from bishopthom for line 92 fixed the IP errors. Only thing is that now the operating systems are not being identified. I am not a coder, so I have no clue how to correct that. But would love to hear anyone else’s ideas.


    Is it possible, bishopthom, that you could clarify the code that should be replaced in your instructions above in addition to the line number… I am using BaStats 1.0β build 8 but the change outlined above had no effect for me.

    Line 92 for me is: $qry .= “, ” . $ua_id;

    Like some of those above, I have trouble relating this to my host (Dreamhost) since it has *only* happened since I upgraded to (after patiently waiting for the dust to settle) and *only* occurs for some IP addresses.

    Failing that (and I don’t really want to abandon BaStats) any other recommended plugins to monitor visitors?

    I found what, I hope, has turned into an instant, quick, and easy fix for this problem, even to the point that it revealed the already-logged IP addresses in their proper form. Perhaps this will be useful to some out there.

    In your databases, check the wp_bas_visitors table’s visit_ip field. In my database, this field was unsigned. I simply changed this attribute, setting it to the blank item in the drop-down. Hey presto! This instantly revealed the masked IPs and, up until this point–maybe a half hour later–the have not returned.

    Now, let’s hope that this didn’t open up a whole new can of worms, eh? 🙂

    This looks like a result – I’ve been running it for 24 hours and the 255’s have disappeared, neither have I seen any of the other problems that I encountered when trying the various php code changes mentioned elsewhere in relation to this problem.

    Nice one. I have *no* idea what this database field is doing (and neither do I need to know) but if anyone knows of any good reason why this is a *bad* idea, please sing out!

    Thanks, RaHarakhte!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘BAStats & Host IP’ is closed to new replies.