Support » Plugin: Genesis Club Lite » Bar doesn't work

  • Resolved sabradavis

    (@sabradavis)


    Hello,

    I have been using your plugin for some time and noticed that the bar will only show with the “Enable Default Bar” selected and therefore on all pages. I want to be able to control what pages it shows up on. I know that there is a page by page control that says “Show bar the top bar on this page” but it doesn’t work. Thanks for your help.

    https://wordpress.org/plugins/genesis-club-lite/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Russell Jamieson

    (@powerblogservice)

    The Bar does works in exactly the way intended.

    You need to ‘Enable Default Bar’ to have the bar work at all.

    The bar then appears automatically on posts and NOT on pages. That is the default behavior. (As normally you would NOT want a bar on your standard pages such as contact, privacy, terms, nor your landing pages, thank you pages, etc)

    However you can override the default behavior on a page by page or post by post basis in the Genesis Club Post settings metabox in the Post Editor

    On posts: the checkbox is labelled “Hide the top bar on this page”

    If you check the box then the bar is NOT displayed on that particular post

    On pages: the checkbox is labelled “Show the top bar on this page”

    If you check the box then the bar is displayed on that particular page

    I hope that makes it clear.

    The “Enable Default Bar” is like a global switch. For example. if you have an time based offer and that offer expires you want to switch the bar off without having to go and edit all the posts/pages on the site to switch if off individually.

    Plugin Author Russell Jamieson

    (@powerblogservice)

    If you need more fine-grained control of the bar then there is the Genesis Club Pro edition of the plugin.

    This has a Genesis Club Top Bar Widget and this allows you to define multiple bars and use a plugin such Widget Logic to decide which bar is displayed on which page.

    For example, on Category A posts you may want to display an offer appropriate to Category A; on Category B posts you may want to display an offer appropriate to Category B, etc. You also may want to have top specific bars on landing pages that aid conversion.

    Thread Starter sabradavis

    (@sabradavis)

    Hello,

    Thank you for the reply. Your explanation of how the bar should work definitely helped me get closer to solving my issue. The plugin does seem to be working properly but for some reason I can’t get it off my home page. Even without “show the bar on this page” selected on my home page, it continues to show. I don’t think its a plugin problem though and probably has something to do with how I have the home page setup. If you know anything about this problem I would appreciate the help but otherwise I’m sure I’ll figure it out.

    Also thank you for clarifying that the pro version of the widget has more precise control. I don’t need it yet but will definitely look into it when I get there.

    Hi Sabra

    It’s not a bug – it is just how it works. The free version has a lot in it, but is not as fully featured as the pro version which has many more functions and more granularity of control.

    The free version assumes that you want the bar on the home page. It does not matter if you used a page as your homepage – the fact that is now, your page is used as a home page so the bar will show. I hope that helps.

    Best
    Liz

    Plugin Author Russell Jamieson

    (@powerblogservice)

    @sabradavis,

    In Genesis Club Lite v1.6 I have added a couple of options to the Genesis Club Top Bar.

    • Hide on home
    • Show only on home

    So to hide the top bar on the home page you need to:

    1. Go to the main Genesis Club Lite > Bar settings
    2. Click the Enable Default Bar checkbox.
    3. On the Location tab click the Hide on home checkbox
    4. Then in the Page Editor on the pages of interest, under Genesis Club Post settings click the “Show top bar” checkbox to show the bar

    Regards

    Russell

    Plugin Author Russell Jamieson

    (@powerblogservice)

    @sabradavis,

    I marked this resolved for now as with v1.6 you have the capability to not show the bar on the home page.

    The default bar is set to show on posts and archives. However, if useful I can add a couple more options on the Location tab:

    • Hide On Posts
    • Hide On Archives

    By default, the bar is not shown on Custom Post Types and Pages however you can switch on the bar on a page-by-page basis in the Genesis Club Post Settings.

    If you need more granular control or be able to show different top bar messages on different pages then you can try the Genesis Club Pro version which has a Top Bar Widget and hence you can control the visibility of multiple bars using a plugin such as Widget Logic or the JetPack Visibility Module

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Bar doesn't work’ is closed to new replies.