WordPress.org

Support

Support » Plugins and Hacks » WP Cookie Banner » [Resolved] Banner appearing on every page

[Resolved] Banner appearing on every page

Viewing 5 replies - 1 through 5 (of 5 total)
  • I think you need to select what page you want it to appear on under settings then WP Cookie Banner – Privacy/Cookie Banner

    Plugin Contributor robertkent

    @robertkent

    Hi Connikoala,

    Mrussell1984 is correct, the only required element is making sure that your Privacy page has been selected. As long as this is done and the testing mode is switched off, the banner should only appear the once on whichever page you land on first (normally the homepage).

    If this is not the case though please contact us again and we can look at it a bit closer.

    Plugin Contributor bavington

    @bavington

    Hi Connikoala,

    Indeed, once the testing mode is switched off (un-checked) the banner should only appear once, on one page until the cookie expires.

    If you’re still seeing the banner on every page this might just be your browser having cached the JavaScript. Please try hard-refreshing your browser with the plugin settings as they are, then refresh the page again and the banner should disappear as normal. This issue won’t be something your visitors see, as it should should be your browser caching and still working off the testing JavaScript.

    Please let us know how you get on. If the bug persists we’ll happily take a closer look for you to see if there is indeed a bug with the plugin.

    James.

    Hi,

    Thank you for the answers – i refreshed the browser and not it is only appearing on one page – great.

    Love this plugin thank you!

    Plugin Contributor bavington

    @bavington

    Thanks Connikoala,

    Really pleased to hear that solved the problem. If you have a moment, we’d really appreciate a quick review on the plugin page to help get our plugin out there!

    James.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Banner appearing on every page’ is closed to new replies.
Skip to toolbar