Support » Theme: Celestial - Lite » Banner

  • Resolved Dave_Jessen



    First of all Thank you for you very cool theme! I really enjoy working with it.
    however there is one thing I can’t seem tot adjust:
    When I upload a header it will appear on the homepage with the nice curves, but is also appears on every other page.

    Is there a way to disable the customized header to appear on every page except the home page?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Theme Author Styled Themes


    Hi Dave…thank you for your kind comment about my theme. For your request, there are a few methods, but each one requires modifying code, some choices are quick and another would be to have me customize the header.php for you or create a new front page template that you can use…I do offer customization services but one method I can provide for you here (but please keep in mind any updates to the theme will overwrite the change which is why doing a custom front page template would be the better solution).

    However, the quick and dirty method is to do this:

    (1) First, backup your theme before you make any changes (good to play safe)

    (2) Open the header.php file and remove this code from around line 125:

    <?php $header_image = get_header_image();
    			if ( ! empty( $header_image ) ) : ?>
    				<div id="st-header-image" >
    					<img src="<?php header_image(); ?>" class="header-image center" height="<?php echo get_custom_header()->height; ?>" width="<?php echo get_custom_header()->width; ?>" alt="<?php bloginfo( 'name' ); ?>" />
    		<?php endif; ?>

    (3) Go to the theme’s options (customizer) and in the “Header Image” tab, disable the Front Page Showcase Curve

    If you decide to put another image or something else in the showcase area of your front page, but not using the WP Custom Header, you can use the Showcase Front Page widget position for this. I recommend the Advanced Text Widget because you can assign it to a specific page ,post etc, and suppress the title too.

    Thank you very Much! It solved my problem.

    Theme Author Styled Themes


    You’re very welcome 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Banner’ is closed to new replies.