WordPress.org

Support

Support » How-To and Troubleshooting » Baffled by my permalink problems

Baffled by my permalink problems

  • I initially had permalinks working great with the /archives/%post_id% prefix. Then I added an “archives,php” template to the theme, and created an “archives” “page” based on that template. At some point I noticed weirdness, and so I eventually deleted the page and the template from my directory. I found that now my permalinks were all screwy. After deleting the tamplate and page they would only give the old “no posts matched your criteria” error. I deleted my .htaccess file, cleared my cache, and all that. Same problem. I had someone else at at another computer (in another location entirely) try and they got the same error. They had never been to my page so it wasn’t cache or cookie problems.

    I eventually found that permalinks will work if I change them to anything else except /archives/%post_id%

    I’m totally baffled. It seems that something got screwed up by having either the template or page called “archives” but they’re all gone now and I’ve totally started witha new .htaccess file.

    Totally baffled.

Viewing 5 replies - 1 through 5 (of 5 total)
  • How exactly do you want to store your archives anyway? If /archives/%post_id% is something that is a problem, for the moment, don’t use it.

    What are the administration settings that you have for your permalinks? What was in that archives file?

    For the moment I have just changed my permalinks to the year/month/etc option, but it was more curiosity than anything else. I’d just like to know why this problem occurs. The archive file just had the category and monthly archives listed. I copied the “archives.php” file from the default template. I then wrote a “page” based on that template with the title and page slug os “Archives” and saved it.

    That’s the problem – the name/title, I guess.
    Read this thread: http://wordpress.org/support/topic.php?id=24290
    And I have seen other also complaining about an archives page called archives causing problem in archives :))

    Moderator James Huff

    @macmanx

    Support Team Rep.

    Just to add another opinion (since I have no problems with archives and have a page titled “Archives”.) You need to have a trailing slash at the end of your permalinks. Use:
    /archives/%post_id%/

    Thanks all. From that other thread I fixed it by changing the page slug. I’m jsut surprised that worked since even when I deleted the page entirely I still had the error! Weirdness.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Baffled by my permalink problems’ is closed to new replies.