Support » Plugin: BadgeOS Community Add-on » Badges are never awarded

  • Resolved JR Nielsen

    (@jurnco)


    With BuddyPress 1.7, I can’t seem to get badges to be rewarded. I set up a simple one activity feed post badge to see how it works, but the user never got the badge. I can see the activity getting logged properly in the Badgeos log, it just never unlocks the award. What could be wrong?

    EDIT: Sorry for the double post! I’d delete one if I knew now.

    http://wordpress.org/extend/plugins/badgeos-community-add-on/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Brian Messenlehner

    (@messenlehner)

    We just made some updates. Please try version 1.0.1

    Thanks Brian, I just tested it but now it seems worse. I have a badge set to look for one activity feed post. When a user posts something it logs three events:

    1. triggered (
    2. xxxxxxx unlocked the “Write and Activity Stream message” step
    3. XXXXXXX triggered badgeos_unlock_step (2x)

    I think this might be a problem with BadgeOS and not necessarily the community plugin specifically because I’m having similiar issues with all of the badge steps.

    I checked the user info in the WP Admin and now it looks like they are getting non existent awards for every step completed, but still no badges.

    onydchic

    (@onydchic)

    Seconding this. Upgraded and users getting their activities logged but still not getting achievements/points unless they’re manually given.

    Seahawksean

    (@seahawksean)

    Am I missing something? How do you manually award bulk badges via email through the BadgeOS/BadgeStack plugin in my WP site?

    Thank you.

    Noting down issues, will definitely investigate further soon.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Badges are never awarded’ is closed to new replies.