WordPress.org

Support

Support » Plugins and Hacks » BadgeOS » [Resolved] BadgeOS trigger not working

[Resolved] BadgeOS trigger not working

  • We’re having trouble with our wordpress site (www.mumsontop.co.nz/wordpress) and making the badges that we are awarding for the different community actions appear on people’s pages. The only way we seem to be able to do it, is to award them manually as the administrators.
    As a member joins a group (Southland for example) we have set a community action to trigger the badge when they join…but after getting many different people to join the Southland group no one is getting a badge!
    Can you offer any suggestions, or see where we’ve gone wrong?

    https://wordpress.org/plugins/badgeos/

Viewing 15 replies - 1 through 15 (of 28 total)
  • Hi mumsontop, my first question is going to be if you’re using our BadgeOS Community Addon at all. It’s a free extension designed to add BadgeOS features/integration to BuddyPress powered websites.

    Hi Michael – yes, we have this plugin installed… and are using the community trigger.

    In the “Achievements” section where you set up your achievement types, have you made sure that the BuddyPress specific checkboxes are enabled? They should be related to activity stream and user profiles, if I recall right.

    /Users/nolanvini/Desktop/Screen Shot 2014-02-25 at 5.28.17 pm.png

    Yes, we think we have every box ticked correctly…

    the above is the achievement level.
    The below is within the actual achievement level.

    /Users/nolanvini/Desktop/Screen Shot 2014-02-25 at 5.31.26 pm.png

    I’m not going to be able to see those images.

    Could you give some of the community activity steps that aren’t working correctly?

    Hopefully the rest of my reply makes sense.

    Just to make sure these parts are clear, I realize it may not be exactly what you’re referring to overall.

    These are the two I mean for the Achievement type settings: http://cl.ly/image/3B3L2l0X0Y44

    The “Profile Achievements” one should add an “Achievements” tab to their profiles when applicable. I see an example of one at http://www.mumsontop.co.nz/wordpress/members/emmabettle/achievements/ with 3 achievements. Since there seems to be a lower amount of users at the moment, I was able to check most of them. If I recall right, about 6 out of 8 had the achievement tab to click, and only 2 didn’t.

    I’m not going to be able to see those images.

    Could you give some of the community activity steps that aren’t working correctly?

    Hopefully the rest of my reply makes sense.

    Just to make sure these parts are clear, I realize it may not be exactly what you’re referring to overall.

    These are the two I mean for the Achievement type settings: http://cl.ly/image/3B3L2l0X0Y44

    The “Profile Achievements” one should add an “Achievements” tab to their profiles when applicable. I see an example of one at http://www.mumsontop.co.nz/wordpress/members/emmabettle/achievements/ with 3 achievements. Since there seems to be a lower amount of users at the moment, I was able to check most of them. If I recall right, about 6 out of 8 had the achievement tab to click, and only 2 didn’t.

    Don’t mind the double post, I was struggling for a moment 🙂

    Emma has badges because I have manually awarded them – as we can’t get the trigger to work.

    I have just (as the admin) awarded her a badge – but she has no tab that lists this under any “achievements”

    Both boxes are ticked as indicated on your screen shot (they were already ticked)

    It also appears that no group activity is showing in the log entries.

    Which triggers are you trying with, so that I can try them on my localhost site to see if I can replicate any of the same issues.

    trying to trigger a membership badge when someone joins their local group.

    I set up a test achievement that was awarded when a user “joined a group” via the “Community activity” steps and it triggered just fine for me.

    So, that doesn’t help you but it does make me wonder if there’s something going on with the rest of your setup that may be preventing the processing. I’m not going to be able to debug much more from my current position. I’d need to be granted higher access via an account.

    Hi Michael
    I can get a badge awarded from an independent action as well as a social action – we seem to be having trouble with group actions.
    I’m happy to give you access – how would you like me to do this? Email?

    set up an account with the email you already have for me.

    Done – if you can help us out it would be wonderful! Specifically the coffee groups – and awarding a badge when someone joins their regional group – all from a trigger.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘[Resolved] BadgeOS trigger not working’ is closed to new replies.
Skip to toolbar