Support » Plugin: BadgeOS » BadgeOS Sensei-Edit Steps

  • Resolved tamritz



    I am using BadgeOS with the Sensei Add-on. I have lessons that are tied to earning badges. Once the steps are created (all of which are completing a Sensei Lesson or Quiz) and I save the draft or publish, the steps disappear from the edit view for the badge. It appears as if the steps were not added at all. However, when viewing the quest in the browser, the steps are clearly there. If I try to add steps again, the old ones plus the new ones will appear in the browser view, even though they are not all visible in the edit view.

    There is no way to go back and edit the steps or change a “step label” in BadgeOS (even if there is a typo). The only work around I have found is to recreate the badge from scratch (after first deleting the old one.) and adding the steps the way I want them. (Of course, they can’t be edited once they are added.)

    Any thoughts?

Viewing 15 replies - 1 through 15 (of 28 total)
  • We’re checking on this one. I’m not very familiar with the Sensai platform, so I’m not the best direct source. Hopefully we have something soon.

    I’m having the same problem as @tamritz. Everything works fine in version 1.3.4, but when you upgrade to 1.3.5 the “add steps” will not save on the edit page.

    What version of Sensei are you two using? Trying to possibly get this debugged.

    I am using Sensei 1.5.1. This was a problem before the update to BadgeOS 1.3.5, by the way, at least for me. Thanks for checking this out.

    Currently I’m using Sensei 1.5.2 with BadgeOS 1.3.4 and I’m having the problem.

    When I go back to Sensei 1.5.1 with BadgeOS 1.3.4, still having a problem, but I don’t have a copy of Sensei 1.4.9 or 1.5.0 to try out.

    So the problem may lie in Sensei 1.5.0 and BadgeOS 1.3.4 / 1.3.5 .

    Could it be a problem on the Sensei BadgeOS addon?

    While I’m not seeing the same issues you two are, I am definitely seeing some things that will need some love.

    I haven’t had issue with disappearing steps or inability to edit them after the fact. I did have issue with the quantity value for earnable amount of times being disabled permanently after selecting something like a quiz to complete.

    I’m testing on both BadgeOS 1.3.4 and 1.3.5 with Sensei 1.5.2 at the moment.

    To be sure, you’re both clicking “Save all steps” first before saving as a draft or publishing, right?

    Sarah, could you send me some updated creds for an admin account? I remembered you sent me some before, but the password doesn’t appear to be valid any more. Perhaps I can see something going on right from a source.

    Yes, most definitely saving before publishing. The steps appear on the published page. AND, if you go back after publishing to edit the steps, it’s as if they are gone. If you are silly enough to add more steps, and then update, then the previous steps PLUS the new ones will appear, and so forth.

    I just sent you login credentials. Thanks for jumping in!


    Hey Michael,

    I ran some more tests while using badgeOS 1.3.4 and Sensei 1.5.1.

    I started making sure I saved before I publish and sometimes the steps would save and sometimes they wouldn’t. So, then I ran a full clean install and it works, but when I go to Sensei 1.5.2 , no go.

    I am having trouble recreating this, even within Sarah’s graciously donated access in her site. I have created some brand new badges, assigned them steps of Sensei activity, and had nothing like what both of you describe.

    Saved the steps
    Saved as a draft first
    Tried in both Firefox and Chrome

    Had no issue editing existing ones, including labels. I did notice the same behavior with the ___ times(s) input where you set how many times a user can earn the achievement, but that was already noted down.

    By this point I’m really starting to scratch my head. Not sure if either of you would know how to record a quick demo example of what you’re seeing, but that’s my best suggestion at this point, other than checking what browser both of you are using, in case it’s a javascript issue.

    Now that I have updated to 1.5.2, the problem is not occurring. Not sure if this is the fix, but I will keep you posted if I encounter the challenge again. Thanks for the time you spent. I see all the steps now on old badges I created, where the steps were not visible before the update. It’s a mystery I supposed. At least I’m not the only one who experienced this, or it would sound like I am crazy, LOL.

    I think this is why I got the nickname of “Venkman” in-company. I occasionally hunt down ghosts in the machine 😀

    It’s a very strange thing in that case. I was trying it on the same setup, same versions, etc that you were but wasn’t seeing the same results. Then you update and they’re gone. Should I claim being a little freaked out? Should I claim Egon(RIP) went and got them for us?

    Now to just have Justin’s go away like that.

    Glad you are the ghosthunter — you have the fortitude it seems! 🙂 It keeps life challenging at any rate!

    I will be interested to hear if Justin’s goes away. Don’t want to go it alone with all the happy fixes.


    Hey Michael,

    I’ll be running my tests today and get back to you. Should I test under BadgeOS 1.3.4 or 1.3.5 with Sensei 1.5.2?

    Well, we want you to stay uptodate with your plugins Justin, so I’m going to go with BadgeOS 1.3.5. Sensei Addon 1.0.0 I believe? and Sensei 1.5.2. That’s the points we’d be trying to fix from, if we can pinpoint the issue.

    Other option: maybe I inherited my dad’s gift to fix stuff just by showing up, and that’s what happened for Sarah. :D. In all seriousness, I wish with that one.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘BadgeOS Sensei-Edit Steps’ is closed to new replies.