WordPress.org

Support

Support » Plugins and Hacks » [Resolved] BadgeOS Reports plugin not deploying

[Resolved] BadgeOS Reports plugin not deploying

  • I cannot get the BadgeOS Reports plugin to activate. I upload the zip file, then when I click Activate I get the message “Are you sure you want to do this?” which links back to the same error message. The only way to get off the page is with the Back button. How can I troubleshoot this? Am I using an old build of the plug-in?

    https://wordpress.org/plugins/badgeos/

Viewing 15 replies - 1 through 15 (of 25 total)
  • What version of the core BadgeOS plugin are you using as well as the Reports plugin?

    We’re using BadgeOS 1.3.4 and BadgeOS Reports 1.0.0

    Thanks!

    Hmm. Confirming the issue on my localhost. Checking on. Thanks for the bug report.

    It’s weird because I’ve deployed this combo in four other environments, two basically identical, two all-but-identical and on the same server, with no issues. What is the what.

    In short, we currently try to set some option values on activation of the plugin, and for some reason, that’s causing the error to trigger. I’m wondering if we’re running it too early somehow. We’ll see more tomorrow when more of our developers are around.

    Just wanted to follow up on this. We still can’t get BadgeOS Reports to work on our main deployment. Any chance of a resolution on this before the coming weekend? I’ve got a crop of new users coming in on Monday.

    Since I know that you definitely have the core BadgeOS plugin installed, I’m willing to do this. If you or someone on your team can access the server to back up the current Reports plugin, please do that.

    This is a slightly modified version that hopefully removes the activation issue, until we can get a permanent solution. http://cl.ly/0Z3b220D3X2D

    Let me know if this works and helps.

    It looks like the modified version doesn’t activate either.

    Would you be willing to let me in to check on things myself?

    oddmonster is this still an issue that’s lingering? or did it resolve itself?

    Hi Michael,

    Thanks for checking back in. Yes, this is still an issue. Can you get in touch with me at audrey at tarrantinstitutedotorg to talk about getting you troubleshooting access? Thanks!

    Alrighty

    Through meticulous tinkering and careful typing, I have managed to get this activated for you, I recommend not touching the activating/deactivating of it until further notice.

    The issue is coming from the plugin itself, and code it tries to run on activation is making it choke. This is the same issue I already have documented and a hopeful fix worked out for, but I also have to go through chain of command to get releases out. Given that it’s a bug that prevents use completely, I want to get this fix elevated and out the door.

    Sadly, the issue tracker is in a private GitHub repo, so I can’t link others to it to contribute.

    Regardless, you’re up and running for the moment.

    Excellent! Thank you very much! And if I’m understanding you correctly, if any of our collaborators run into this issue with their BadgeOS sites, we should just tell them to sit tight for the next version of the plugin?

    Thanks again. Much appreciated.

    Ideally they won’t have to wait long, but I can’t guarantee anything with that. I really want to get this patched and fixed because it prevents everyone from using it.

    Who at WebDev is in charge of this plugin? It seems like it has been abandoned or at the very least no one cares about it.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] BadgeOS Reports plugin not deploying’ is closed to new replies.