Support » Plugin: BadgeOS » BadgeOS not generating BuddyPress activities after applying updates

  • Resolved kcurlsjr

    (@kcurlsjr)


    Anyone run into problems with earned achievements not creating a BuddyPress activity?

    I recently applied a slew of updates to my site, the most relevant of which include:
    BuddyPress 2.2.3.1 and BadgeOS 1.4.4.

    Now an activity isn’t generated when users earn an achievement (nothing shows up in either the site wide activity feed or the users’ personal activity feed.

    The odd thing is that activities are still being generated when admins earn achievements.

    Any thoughts on what could be going on?

    https://wordpress.org/plugins/badgeos/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Michael Beckwith

    (@tw2113)

    The BenchPresser

    Not sure at the moment, to be honest. Are they showing in the admin side? or are they missing from there as well?

    The users are earning the achievements. It appears on their profile, an entry in the badgeOS log is created, and they receive the modal pop up from the congratulations add-on.

    It is just the BuddyPress activity that is missing from all the from-end activity feeds and from the activity tab on the WordPress back-end.

    Again, is for regular users… for some reason, everything is fine when admins earn achievements.

    Michael Beckwith

    (@tw2113)

    The BenchPresser

    I wonder if this issue is related: https://github.com/opencredit/BadgeOS-Community-Add-on/issues/46

    I could easily see 2 links being present, and thus being considered “spam”.

    Yup, that was it.

    Increasing the link moderation count limit fixed it.

    Thanks, Michael!

    Michael Beckwith

    (@tw2113)

    The BenchPresser

    Hoping to have this taken care of right away in the next release of the Community Addon.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘BadgeOS not generating BuddyPress activities after applying updates’ is closed to new replies.