WordPress.org

Forums

Bad YSlow Score (4 posts)

  1. mrerikmt
    Member
    Posted 2 years ago #

    Quite a while ago my site had a bad YSlow Score so I installed W3TC with a CDN and my YSLow Score went up to 95.

    I just checked it and my YSlow score is 73.

    I get an F on "use CDN", so I went into W3TC and ran the test to see if Cloudfront was working properly and it indicated that it was.

    I am also getting an F for "make fewer http requests" so I went and made sure all the minify settings were as they should be. Everything is enabled and I used the "help wizard" and did what it said to do.

    YSlow score is now 75, so no real improvement.

    Anyone know why it would be telling me to use CDN even though I already am?

    or why my site is making so many http requests when I have W3TC Minify enabled?

    I also ran Firebug and the only thing that was running a little slow was my homepage which got a load time of 3.2 sec. Everything else was loading in milliseconds.

    templemountaintea.com

    Thanks for any help.

  2. mrerikmt
    Member
    Posted 2 years ago #

    I thought I should add that the "make fewer http requests" indicated this specifically:

    This page has 26 external Javascript scripts. Try combining them into one.
    This page has 15 external stylesheets. Try combining them into one.
    This page has 8 external background images. Try combining them with CSS sprites.

    All external.

    My host does not support mod_deflate or mod_gzip.

  3. mrerikmt
    Member
    Posted 2 years ago #

    Update:

    I went back and checked Yslow and it is now giving me an A for "Use CDN".

    Apparently the site just needed some time.

    Still getting some slow down from "make fewer http requests"

  4. Frederick Townes
    Member
    Posted 2 years ago #

    Well tools are giving advice, there's far more to consider than the feedback from any given automated tool.

Topic Closed

This topic has been closed to new replies.

About this Topic