Support » Plugin: WordPress Mobile Pack - Mobile Plugin for Progressive Web Apps & Hybrid Mobile Apps » Bad url interpretation = no posts/pages showed up

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor anghelalexandra

    (@anghelalexandra)

    Hi there,

    The Progressive Web App / mobile app from the plugin is an application that runs in the browser and uses URLs with hashtag (#). These URLs are equivalent with the ones from the desktop version. Just to clarify, is there something that is not working on the mobile app?

    yes, on the mobile app any blog post o page category can be reached.
    Seems that any post will be associated wth one category in the mobile version, otherwise in the desktop version the same category has 1 or more posts related to.

    How can I fix that?
    Thank you!

    Plugin Contributor anghelalexandra

    (@anghelalexandra)

    Hi again,

    I don’t quite understand the question – in the mobile app, a category can have 1 or more posts as well.

    Do you want to display all the categories for a post on the post details page?

    Or …

    Do you want to add support for related posts – meaning on the post details page, have links to other posts from the same category?

    Alexandra,

    I’m not talking about related post. Using your plugin, no posts in each category of my site can be read from the mobile app. The app shows correctly the categories but not the linked posts. The app says there is no post associated with a particular category, but posts are well visible in the desktop version of my site. I think it’s a problem of how your app generates URLs.

    For example:

    The desktop url of one of my category is:
    http://www.primagravidanza.it/category/dritte/

    and here is how the WP Mobile Pack 3.2 understand the URL:
    http://www.primagravidanza.it/category/dritte/64#/category/esperienze/44

    Can you help???

    Thank you!

    Plugin Contributor anghelalexandra

    (@anghelalexandra)

    The URL on the mobile app should be http://www.primagravidanza.it/#/category/esperienze/44.

    Can you please explain how you were redirected to this one? http://www.primagravidanza.it/category/dritte/64#/category/esperienze/44

    if I enable your plugin, the mobile version of my site shows the categories with this link http://www.primagravidanza.it/category/dritte/64#/category/esperienze/44

    I’ve taken the link by copying it from my smartphone, and no posts associated with those categories are shown, the message displayed is “no post is available for this category ” but all the posts for the same category are shown on the desktop version.

    Plugin Contributor anghelalexandra

    (@anghelalexandra)

    I was able to see the problem when you have activated the plugin. The API that is exporting the content for the mobile app can’t be reached. That’s why the categories appear to be empty.

    It looks like a permissions problem or an error on the server side (can be from another plugin as well). If I access one of the endpoints from the API in the browser, it works, but when the app is trying to get the content – there’s an error on the server and it can’t load.

    If you have PHP errors logging enabled, you can connect via FTP and should be able to see the exact error in an error.log file.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Bad url interpretation = no posts/pages showed up’ is closed to new replies.