Support » Plugin: WP Fastest Cache » Bad Request – KeyCDN origin URL shift from http to https

  • Hi,

    I noticed when I had force enabled HTTPS on all of my pages, most of my assets weren’t loading. So I figure out that my CDN was still trying to pull data from http:// not https://, thus making my browser unhappy. I went over to my settings at “Other CDN Providers” and change my origin url from http:// to https://. A few weeks when I had made this change, I did not see any errors from Fastest Cache. But just right now when I looked at my code and it appears that Fastest Cache stopped delivering my assets from my CDN from that point on when I had changed my origin url.

    So now that I found out that it has not been loading, I tried to troubleshoot this problem by changing the Zones’ Original URL in KeyCDN to match that in my Fastest Cache setting, which is https://. After KeyCDN deployed the zone changes. I tried to resave the Fastest Cache settings and it throws “Bad Request”. I made sure that the Zone URL and the Origin URLs are identical, but it’s still showing the error.

    Any thoughts on how I can make this work again?

    Thank you,

    Exius

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Bad Request – KeyCDN origin URL shift from http to https’ is closed to new replies.