Support » Plugin: LiteSpeed Cache » Bad page/post edit redirection

  • Resolved mamasiga

    (@mamasiga)


    In WP Multisite with WP Litespeed plugin active (network or single site) , when I try to edit any page or post from WP top bar on front-end, I always get redirected to edit home page instead.

    The only way to edit correct post/page, is to look it up under Posts/Pages Menu in WP dashboard.

    This is already happening for several Litespeed versions – for last 3-4 months at least. With earlier versions, this was never a problem.

    When I deactivate Litespeed plugin, editing page or post from front-end WP top bar works correctly.

    Thanks for attention.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Hai Zheng⚡

    (@hailite)

    Yes it’s a known issue. Because after admin bar is cached, it will always give the same link for that edit button.

    We are now working on it.

    Thread Starter mamasiga

    (@mamasiga)

    Wow, thank you for extremely fast answer.

    Is there an option to turn off caching of admin bar?

    Plugin Support Hai Zheng⚡

    (@hailite)

    That is one of the solutions. Will see in next week’s release 🙂

    Plugin Support Hai Zheng⚡

    (@hailite)

    Please turn off Cache Admin Bar in ESI tab to give it a try.

    Plugin Support Hai Zheng⚡

    (@hailite)

    Please ignore the previous post. The current admin bar ESI block used same address for all pages, so even turn it off, still can’t generate different content for different pages.

    Will fix it in this week’s release.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bad page/post edit redirection’ is closed to new replies.