Support » Plugin: Simple Custom CSS and JS » Bad issue using this plugin

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Diana Burduja

    (@diana_burduja)

    I tested the plugin for PHP 7.0.15 and haven’t encountered any errors/warnings. Also tested with Apache FastCGI, even if this has no influence whatsoever on the plugin execution.

    I’d appreciate you helping me find the error, so I can fix it and spare future users from the frustration you had.

    “FastCGI header error” occurs whenever there is a PHP error or warning. Could you please check in the /wp-content/debug.log file what was exactly the error you were getting?

    Hi Diana, thanks for reply.

    Here some details:

    PHP 7.0.8 (cli) (built: Jun 24 2016 11:16:20) ( NTS )
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
        with Zend OPcache v7.0.8, Copyright (c) 1999-2016, by Zend Technologies
    

    – opache enabled
    – AWS EC2 bitnami wordpress instance (t2.medium type) with Apache
    – WordPress version 4.5.6
    – apache modrewite enabled

    On this instance we don’t have any particular configuration for Apache and PHP and we have very few plugins installed as is a little website, just a landing page. With little traffic.

    Log error from /opt/bitnami/apache2/logs/error_log :

    [Thu Mar 02 09:17:31.321940 2017] [proxy_fcgi:error] [pid 5752:tid 140069620807424] [client xxx.xxx.xxx.xxx:55217] AH01067: Failed to read FastCGI header
    [Thu Mar 02 09:17:31.321971 2017] [proxy_fcgi:error] [pid 5752:tid 140069620807424] (104)Connection reset by peer: [client xxx.xxx.xxx.xxx:55217] AH01075: Error dispatching request to : 
    [Thu Mar 02 09:17:31.474761 2017] [proxy_fcgi:error] [pid 5752:tid 140069620807424] [client xxx.xxx.xxx.xxx:55217] AH01067: Failed to read FastCGI header
    [Thu Mar 02 09:17:31.474787 2017] [proxy_fcgi:error] [pid 5752:tid 140069620807424] (104)Connection reset by peer: [client xxx.xxx.xxx.xxx:55217] AH01075: Error dispatching request to : 
    [Thu Mar 02 09:17:53.689250 2017] [proxy_fcgi:error] [pid 5753:tid 140069822232320] [client xxx.xxx.xxx.xxx:55242] AH01071: Got error 'PHP message: PHP Notice:  Undefined offset: 0 in /opt/bitnami/apps/wordpress/htdocs/wp-includes/plugin.php on line 925\nPHP message: PHP Notice:  Undefined offset: 0 in /opt/bitnami/apps/wordpress/htdocs/wp-includes/plugin.php on line 943\n', referer: http://www.xxx.it/wp-admin/options-permalink.php
    

    And from /opt/bitnami/php/var/log/php-fpm.log :

    [02-Mar-2017 09:17:31] WARNING: [pool wordpress] child 6277 exited on signal 11 (SIGSEGV - core dumped) after 160.012964 seconds from start
    [02-Mar-2017 09:17:31] WARNING: [pool wordpress] child 5740 exited on signal 11 (SIGSEGV - core dumped) after 230.038305 seconds from start
    

    And here you can find the whole snapshot of our instance:

              
    == Server Environment ==
      Operating System: Linux
      Software: Apache
      MySQL version: 5.7.13
      PHP Version: 7.0.8
      PHP Max Input Vars: 1000
      PHP Max Post Size: 40M
      GD Installed: Yes
      Elementor Library: Connected
    
    == WordPress Environment ==
      Version: 4.5.6
      Site URL: http://www.xxx.it
      Home URL: http://www.xxx.it
      WP Multisite: No
      Max Upload Size: 40 MB
      Memory limit: 40M
      Permalink Structure: /%year%/%monthnum%/%day%/%postname%/
      Language: it-IT
      Timezone: 1
      Debug Mode: Inactive
    
    == Theme ==
      Name: twentysixteen Child Theme
      Version: 1.0.0
      Author: Elementor.com
      Child Theme: Yes
      Parent Theme Name: Twenty Sixteen
      Parent Theme Version: 1.2
      Parent Theme Author: the WordPress team
    
    == User ==
      Role: administrator
      WP Profile lang: it_IT
      User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
    
    == Active Plugins ==
      All In One WP Security
        Version: 4.2.5
        Author: Tips and Tricks HQ, Peter, Ruhul, Ivy
    
      BackWPup
        Version: 3.3.4
        Author: Inpsyde GmbH
    
      Duplicate Post
        Version: 3.1.2
        Author: Enrico Battocchi
    
      Elementor
        Version: 1.2.4
        Author: Elementor.com
    
      Insert Headers and Footers
        Version: 1.3.3
        Author: WPBeginner
    
      iubenda Cookie Solution
        Version: 1.14.2
        Author: iubenda
    
      Search & Replace
        Version: 3.1.2
        Author: Inpsyde GmbH
    
      WP-Mail-SMTP
        Version: 0.10.1
        Author: Callum Macdonald
    
      WP Maintenance Mode
        Version: 2.0.9
        Author: Designmodo
    
      Yoast SEO
        Version: 4.4
        Author: Team Yoast
    
            

    Instead of Insert Headers and Footers plugin, before we were using Simple Custom CSS and JS current version (2.10) and was doing us the issue Failed to read FastCGI header error.

    We fixed the issue by disabling Simple Custom CSS and JS plugin.

    Hope it helps.

    • This reply was modified 2 years, 8 months ago by  durantediego.
    Plugin Author Diana Burduja

    (@diana_burduja)

    You need to increase the memory limit. Right now you have 40M memory limit, when even 64M is small for WordPress (128M is recommended). On top of that you are running Opcache (Opcache speeds up your scripts by storing the compiled scripts in the memory).

    When you disabled the Simple Custom CSS and JS plugin, you simply released some memory.

    I assumed you read the ServerPilot article related to the “Failed to read FastCGI header” error. Please read the last part entitled “Running Out of Memory”. You can test my assumption by checking out your /var/log/syslog file.

    • This reply was modified 2 years, 8 months ago by  Diana Burduja.

    I checked /var/log/syslog* files and I have no errors related to memory.

    I also have other sites, with traffic and many plugins, that are using 40M memory with no issues.

    If your plugin requires more memory to be used, say it into documentation or inside wordpress dashboard may showing an alert during activation/installation.

    Regarding “On top of that you are running Opcache (Opcache speeds up your scripts by storing the compiled scripts in the memory).
    When you disabled the Simple Custom CSS and JS plugin, you simply released some memory.”

    I restarted many times apache and php realising memory and error was there until I deactivated your plugin.

    • This reply was modified 2 years, 8 months ago by  durantediego.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Bad issue using this plugin’ is closed to new replies.